summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorLeonard Göhrs <l.goehrs@pengutronix.de>2024-11-01 13:40:42 +0100
committerKhem Raj <raj.khem@gmail.com>2024-11-01 06:43:16 -0700
commit1d47796fcf9613e4ca2f2c6beeb6f447d443fca0 (patch)
tree205d67aba49d59c9e7a0387865475a45d335a752 /meta-oe/recipes-support
parent08934d75ae8aa050a8632c0637558290dff34705 (diff)
downloadmeta-openembedded-1d47796fcf9613e4ca2f2c6beeb6f447d443fca0.tar.gz
bcu: add nxp board control utilities version 1.1.100
The bcu command can be used to communicate with board control hardware on NXP EVK development boards to: - reset / power cycle the board into a specified boot mode. - monitor the power consumption. - read / write the eeprom content. - measure temperatures. - etc. Supported boards are e.g.: - i.MX8MP-EVK - i.MX8DXL-EVK - i.MX8ULP-EVK - i.MX93-EVK The tool can either be built for the target architecture to control a board from a system running Yocto (less common) or for the host architecture to run it via `oe-run-native bcu-native bcu`. Signed-off-by: Leonard Göhrs <l.goehrs@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch38
-rw-r--r--meta-oe/recipes-support/bcu/bcu_1.1.100.bb23
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch b/meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch
new file mode 100644
index 000000000..f4c0be19b
--- /dev/null
+++ b/meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch
@@ -0,0 +1,38 @@
1From ef1aaeee984ab13dab5d46c73e9b207cbdf62c55 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Leonard=20G=C3=B6hrs?= <l.goehrs@pengutronix.de>
3Date: Wed, 20 Dec 2023 14:37:20 +0100
4Subject: [PATCH] CMakeLists: do not use vendored libcurl
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [upstream ticket https://github.com/nxp-imx/bcu/issues/17]
10
11Signed-off-by: Leonard Göhrs <l.goehrs@pengutronix.de>
12---
13 CMakeLists.txt | 5 +++--
14 1 file changed, 3 insertions(+), 2 deletions(-)
15
16diff --git a/CMakeLists.txt b/CMakeLists.txt
17index 3475179..bfecdb0 100644
18--- a/CMakeLists.txt
19+++ b/CMakeLists.txt
20@@ -17,15 +17,16 @@ pkg_check_modules(LIBFTDI REQUIRED libftdi1)
21 pkg_check_modules(LIBYAML REQUIRED yaml-0.1)
22 pkg_check_modules(LIBOPENSSL REQUIRED openssl)
23 pkg_check_modules(LIBUSB REQUIRED libusb-1.0)
24+pkg_check_modules(LIBCURL REQUIRED libcurl)
25 project(bcu)
26-include_directories(${LIBUSB_INCLUDE_DIRS} ${LIBFTDI_INCLUDE_DIRS}include ${PROJECT_SOURCE_DIR}/libftdi/src ${LIBYAML_INCLUDEDIR} ${PROJECT_SOURCE_DIR}/libcurl/include)
27+include_directories(${LIBUSB_INCLUDE_DIRS} ${LIBFTDI_INCLUDE_DIRS}include ${LIBYAML_INCLUDEDIR})
28 include_directories(${PROJECT_SOURCE_DIR})
29
30 message("operation system is ${CMAKE_SYSTEM}")
31 if (LINUX)
32 add_executable(bcu bcu.c port.c chip.c board.c bcu_parser.c bcu_yaml.c bcu_https.c bcu_ftdi_eeprom.c)
33 link_directories(${LIBUSB_LIBRARY_DIRS} ${LIBFTDI_LIBRARY_DIRS} ${LIBYAML_LIBRARY_DIRS})
34- target_link_libraries (bcu ${LIBUSB_LIBRARIES} ${LIBFTDI_LIBRARIES} ${LIBYAML_LIBRARIES} ${PROJECT_SOURCE_DIR}/libcurl/build.bcu/lib/libcurl.a -lpthread -lssl -lcrypto -lm)
35+ target_link_libraries (bcu ${LIBUSB_LIBRARIES} ${LIBFTDI_LIBRARIES} ${LIBYAML_LIBRARIES} -lcurl -lpthread -lssl -lcrypto -lm)
36 execute_process( COMMAND ${PROJECT_SOURCE_DIR}/create_version_h.sh ${PROJECT_SOURCE_DIR}
37 COMMAND ${PROJECT_SOURCE_DIR}/build_libs.sh ${PROJECT_SOURCE_DIR})
38 install(TARGETS bcu DESTINATION bin)
diff --git a/meta-oe/recipes-support/bcu/bcu_1.1.100.bb b/meta-oe/recipes-support/bcu/bcu_1.1.100.bb
new file mode 100644
index 000000000..bf6e4f4b6
--- /dev/null
+++ b/meta-oe/recipes-support/bcu/bcu_1.1.100.bb
@@ -0,0 +1,23 @@
1SUMMARY = "NXP Board Control Utilities"
2DESCRIPTION = "The NXP Board Control Utilities are able to control various \
3 features of NXP i.MX evaluation boards (EVK) from a host \
4 computer. \
5 Features like resetting the board, selecting the boot mode, \
6 monitoring power consumption, programming the EEPROM and others"
7HOMEPAGE = "https://github.com/nxp-imx/bcu"
8SECTION = "devel"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=884d48c2aa7b82e1ad4a33909fab24b6"
11
12SRC_URI = "git://github.com/nxp-imx/bcu;protocol=https;branch=master \
13 file://0001-CMakeLists-do-not-use-vendored-libcurl.patch \
14 "
15SRCREV = "c34d89b29f3d0d12793cd78b194d2f1d11728baf"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "curl libyaml libusb1 openssl libftdi"
20
21inherit cmake pkgconfig
22
23BBCLASSEXTEND = "native nativesdk"