summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-24 23:15:43 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-25 23:08:11 -0700
commit03b66442a5bd2928d84a222d0e949bbaca3304c8 (patch)
treef5d0147ea8ec52316e2c627937eb3ff0d19a2f53 /meta-oe/recipes-support
parent7d099808f0b6dcba62851a4976e1bc0c6a51d084 (diff)
downloadmeta-openembedded-03b66442a5bd2928d84a222d0e949bbaca3304c8.tar.gz
libteam: Include missing headers for strrchr and memcmp
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch46
-rw-r--r--meta-oe/recipes-support/libteam/libteam_1.31.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch b/meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch
new file mode 100644
index 000000000..5f8e56177
--- /dev/null
+++ b/meta-oe/recipes-support/libteam/libteam/0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch
@@ -0,0 +1,46 @@
1From 49693cac37ee35ff673240c8060201efe0d999c2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 24 Aug 2022 22:27:03 -0700
4Subject: [PATCH] teamd: Include missing headers for strrchr and memcmp
5
6Compiler does not see the prototype for these functions otherwise and
7build fails e.g.
8
9| ../../git/teamd/teamd_phys_port_check.c:52:10: error: call to undeclared library function 'strrchr' with type 'char *(const char *, int)'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
10| start = strrchr(link, '/');
11| ^
12
13Upstream-Status: Submitted [https://github.com/jpirko/libteam/pull/68]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 teamd/teamd_phys_port_check.c | 1 +
17 teamd/teamd_runner_loadbalance.c | 1 +
18 2 files changed, 2 insertions(+)
19
20diff --git a/teamd/teamd_phys_port_check.c b/teamd/teamd_phys_port_check.c
21index 1eec129..c2454ab 100644
22--- a/teamd/teamd_phys_port_check.c
23+++ b/teamd/teamd_phys_port_check.c
24@@ -19,6 +19,7 @@
25
26 #include <stdio.h>
27 #include <errno.h>
28+#include <string.h>
29 #include <sys/types.h>
30 #include <sys/stat.h>
31 #include <unistd.h>
32diff --git a/teamd/teamd_runner_loadbalance.c b/teamd/teamd_runner_loadbalance.c
33index a581472..421a7c6 100644
34--- a/teamd/teamd_runner_loadbalance.c
35+++ b/teamd/teamd_runner_loadbalance.c
36@@ -17,6 +17,7 @@
37 * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
38 */
39
40+#include <string.h>
41 #include <sys/socket.h>
42 #include <linux/netdevice.h>
43 #include <team.h>
44--
452.37.2
46
diff --git a/meta-oe/recipes-support/libteam/libteam_1.31.bb b/meta-oe/recipes-support/libteam/libteam_1.31.bb
index ad8438901..023cea903 100644
--- a/meta-oe/recipes-support/libteam/libteam_1.31.bb
+++ b/meta-oe/recipes-support/libteam/libteam_1.31.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://github.com/jpirko/libteam;branch=master;protocol=https \
13 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ 13 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \
14 file://0001-team_basic_test.py-switch-to-python3.patch \ 14 file://0001-team_basic_test.py-switch-to-python3.patch \
15 file://0001-team_basic_test.py-check-the-return-value.patch \ 15 file://0001-team_basic_test.py-check-the-return-value.patch \
16 file://0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch \
16 file://run-ptest \ 17 file://run-ptest \
17 " 18 "
18SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158" 19SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158"