summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/zbar/zbar_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2021-01-30 15:57:46 +0100
committerKhem Raj <raj.khem@gmail.com>2021-01-30 22:56:51 -0800
commit62a58a0186343de64027f7260d8c76320f8b17bf (patch)
treeff3f912f092d9d5dbad922a4e7c1f91898402685 /meta-oe/recipes-support/zbar/zbar_git.bb
parentead30c4c7e00410d9120b17a841c2552ce2b32a0 (diff)
downloadmeta-openembedded-62a58a0186343de64027f7260d8c76320f8b17bf.tar.gz
zbar: use 4 spaces for indentation
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/zbar/zbar_git.bb')
-rw-r--r--meta-oe/recipes-support/zbar/zbar_git.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta-oe/recipes-support/zbar/zbar_git.bb b/meta-oe/recipes-support/zbar/zbar_git.bb
index 5cb7baae3..a33aa2c96 100644
--- a/meta-oe/recipes-support/zbar/zbar_git.bb
+++ b/meta-oe/recipes-support/zbar/zbar_git.bb
@@ -10,8 +10,8 @@ LICENSE = "LGPL-2.1"
10LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5e9ee833a2118adc7d8b5ea38e5b1cef" 10LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5e9ee833a2118adc7d8b5ea38e5b1cef"
11 11
12SRC_URI = "git://github.com/mchehab/zbar.git;branch=master \ 12SRC_URI = "git://github.com/mchehab/zbar.git;branch=master \
13 file://0001-qt-Create-subdir-in-Makefile.patch \ 13 file://0001-qt-Create-subdir-in-Makefile.patch \
14 file://0002-zbarcam-Create-subdir-in-Makefile.patch \ 14 file://0002-zbarcam-Create-subdir-in-Makefile.patch \
15" 15"
16SRCREV = "89e7900d85dd54ef351a7ed582aec6a5a5d7fa37" 16SRCREV = "89e7900d85dd54ef351a7ed582aec6a5a5d7fa37"
17 17
@@ -21,15 +21,15 @@ PV = "0.23.1+git${SRCPV}"
21DEPENDS += "xmlto-native" 21DEPENDS += "xmlto-native"
22 22
23PACKAGECONFIG ??= "\ 23PACKAGECONFIG ??= "\
24 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ 24 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
25" 25"
26 26
27PACKAGECONFIG ??= "video python3" 27PACKAGECONFIG ??= "video python3"
28 28
29inherit autotools pkgconfig gettext \ 29inherit autotools pkgconfig gettext \
30 ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)} \ 30 ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)} \
31 ${@bb.utils.contains('PACKAGECONFIG', 'gtk3', 'gobject-introspection', '', d)} \ 31 ${@bb.utils.contains('PACKAGECONFIG', 'gtk3', 'gobject-introspection', '', d)} \
32 ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)} 32 ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)}
33 33
34PACKAGECONFIG[x11] = "--with-x, --without-x, libxv" 34PACKAGECONFIG[x11] = "--with-x, --without-x, libxv"
35PACKAGECONFIG[video] = "--enable-video, --disable-video, v4l-utils libv4l" 35PACKAGECONFIG[video] = "--enable-video, --disable-video, v4l-utils libv4l"
@@ -40,15 +40,15 @@ PACKAGECONFIG[qt5] = "--with-qt5, --without-qt5, qtbase qtbase-native qtx11extra
40PACKAGECONFIG[imagemagick] = "--with-imagemagick, --without-imagemagick, imagemagick" 40PACKAGECONFIG[imagemagick] = "--with-imagemagick, --without-imagemagick, imagemagick"
41 41
42FILES_${PN} += "${bindir} \ 42FILES_${PN} += "${bindir} \
43 ${@bb.utils.contains('DEPENDS', 'python3-native', '${libdir}', '', d)} \ 43 ${@bb.utils.contains('DEPENDS', 'python3-native', '${libdir}', '', d)} \
44" 44"
45 45
46CPPFLAGS_append = "\ 46CPPFLAGS_append = "\
47 ${@bb.utils.contains('PACKAGECONFIG', 'qt5', '\ 47 ${@bb.utils.contains('PACKAGECONFIG', 'qt5', '\
48 -I${STAGING_INCDIR}/QtX11Extras \ 48 -I${STAGING_INCDIR}/QtX11Extras \
49 -I${STAGING_INCDIR}/dbus-1.0 \ 49 -I${STAGING_INCDIR}/dbus-1.0 \
50 -I${STAGING_LIBDIR}/dbus-1.0/include \ 50 -I${STAGING_LIBDIR}/dbus-1.0/include \
51 ', '', d)} \ 51 ', '', d)} \
52" 52"
53 53
54TARGET_CXXFLAGS_append = " -fPIC" 54TARGET_CXXFLAGS_append = " -fPIC"