diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-08-14 22:04:33 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-08-22 15:49:23 +0200 |
commit | b415e2a372b555a3264359345e6aa52c10c9e1d7 (patch) | |
tree | c42d0a05df9dd7d4e2091f54c3eeb750a234bff3 /meta-oe/recipes-support/udisks | |
parent | 30eb09f3bbb9583a4e7181858488f6259f4b381e (diff) | |
download | meta-openembedded-b415e2a372b555a3264359345e6aa52c10c9e1d7.tar.gz |
udisks2: Update to 2.1.7
Fix below build with musl while here
| ../../udisks-2.1.7/udisks/udisksclient.c:2004:6: warning: '__GNUC_PREREQ' is not defined, evaluates to 0 [-Wundef]
| # if __GNUC_PREREQ(4,6) || __clang__
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/udisks')
-rw-r--r-- | meta-oe/recipes-support/udisks/udisks2/non-gnu-libc.patch | 26 | ||||
-rw-r--r-- | meta-oe/recipes-support/udisks/udisks2_2.1.7.bb (renamed from meta-oe/recipes-support/udisks/udisks2_2.1.5.bb) | 8 |
2 files changed, 31 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/udisks/udisks2/non-gnu-libc.patch b/meta-oe/recipes-support/udisks/udisks2/non-gnu-libc.patch new file mode 100644 index 0000000000..98e6c75f24 --- /dev/null +++ b/meta-oe/recipes-support/udisks/udisks2/non-gnu-libc.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | musl does not define __GNUC_PREREQ therefore check for C library being glibc | ||
2 | if not then define the macro | ||
3 | |||
4 | Upstream-Status: Pending | ||
5 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
6 | Index: udisks-2.1.7/udisks/udisksclient.c | ||
7 | =================================================================== | ||
8 | --- udisks-2.1.7.orig/udisks/udisksclient.c | ||
9 | +++ udisks-2.1.7/udisks/udisksclient.c | ||
10 | @@ -27,8 +27,15 @@ | ||
11 | #include "udisksobjectinfo.h" | ||
12 | |||
13 | /* For __GNUC_PREREQ usage below */ | ||
14 | -#ifdef __GNUC__ | ||
15 | +#ifdef __GLIBC__ | ||
16 | # include <features.h> | ||
17 | +#else | ||
18 | +#if defined(__GNUC__) | ||
19 | +#define __GNUC_PREREQ(__maj, __min) \ | ||
20 | + (__GNUC__ > (__maj) || __GNUC__ == (__maj) && __GNUC_MINOR__ >= (__min)) | ||
21 | +#else | ||
22 | +#define __GNUC_PREREQ(__maj, __min) 0 | ||
23 | +#endif | ||
24 | #endif | ||
25 | |||
26 | /** | ||
diff --git a/meta-oe/recipes-support/udisks/udisks2_2.1.5.bb b/meta-oe/recipes-support/udisks/udisks2_2.1.7.bb index f365cfaaf5..34762ddc65 100644 --- a/meta-oe/recipes-support/udisks/udisks2_2.1.5.bb +++ b/meta-oe/recipes-support/udisks/udisks2_2.1.7.bb | |||
@@ -7,9 +7,11 @@ DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d) | |||
7 | 7 | ||
8 | RDEPENDS_${PN} = "acl" | 8 | RDEPENDS_${PN} = "acl" |
9 | 9 | ||
10 | SRC_URI = "http://udisks.freedesktop.org/releases/udisks-${PV}.tar.bz2" | 10 | SRC_URI = "http://udisks.freedesktop.org/releases/udisks-${PV}.tar.bz2 \ |
11 | SRC_URI[md5sum] = "73632501002e6de8244f831e38b2b98e" | 11 | file://non-gnu-libc.patch \ |
12 | SRC_URI[sha256sum] = "2cfcf560447ea44cba2a683342c7062aaaf35e4eb554bed64ac2dd55a70a5fb6" | 12 | " |
13 | SRC_URI[md5sum] = "8bccd36573b75286538bd5bd2c424f45" | ||
14 | SRC_URI[sha256sum] = "abae2bb3bdc691ca13c1e4c244630b8c881c4f3b35c207299f1b39b7bec83785" | ||
13 | 15 | ||
14 | inherit autotools systemd gtk-doc gobject-introspection | 16 | inherit autotools systemd gtk-doc gobject-introspection |
15 | 17 | ||