diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-05-23 22:07:22 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-05-24 10:11:28 -0700 |
commit | 9d63ad02b3d8e3a1931f7224f4cdb619e687c8bd (patch) | |
tree | 58cc48a234e1deec5a34f028c21d6cf5b55fd863 /meta-oe/recipes-support/udisks | |
parent | 07d46c62614af8ff98ce42a28bbeb5fb2549d11a (diff) | |
download | meta-openembedded-9d63ad02b3d8e3a1931f7224f4cdb619e687c8bd.tar.gz |
udisks: Remove bash dependency
There are couple of scripts which explicitly calls out for bash
interpreter but there is nothing bash specific about them, so let
it use sh interpreter.
Fixes
ERROR: QA Issue: /usr/libexec/udisks-helper-mdadm-expand contained in package udisks requires /bin/bash, but no providers found in RDEPENDS_udisks? [file-rdeps]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/udisks')
-rw-r--r-- | meta-oe/recipes-support/udisks/udisks/0001-udisks-helper-Use-sh-interpreter-instead-of-bash.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-support/udisks/udisks_1.0.5.bb | 1 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/udisks/udisks/0001-udisks-helper-Use-sh-interpreter-instead-of-bash.patch b/meta-oe/recipes-support/udisks/udisks/0001-udisks-helper-Use-sh-interpreter-instead-of-bash.patch new file mode 100644 index 0000000000..ef7f6f9c32 --- /dev/null +++ b/meta-oe/recipes-support/udisks/udisks/0001-udisks-helper-Use-sh-interpreter-instead-of-bash.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 44953e5501e92c87611be45221338004e8032a74 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 23 May 2019 22:00:14 -0700 | ||
4 | Subject: [PATCH] udisks-helper: Use sh interpreter instead of bash | ||
5 | |||
6 | These scripts do not require bash, since they do not use any bash | ||
7 | specific extentions | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/helpers/udisks-helper-change-luks-password | 2 +- | ||
13 | src/helpers/udisks-helper-mdadm-expand | 2 +- | ||
14 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/src/helpers/udisks-helper-change-luks-password b/src/helpers/udisks-helper-change-luks-password | ||
17 | index edcf6c9..c71fc72 100755 | ||
18 | --- a/src/helpers/udisks-helper-change-luks-password | ||
19 | +++ b/src/helpers/udisks-helper-change-luks-password | ||
20 | @@ -1,4 +1,4 @@ | ||
21 | -#!/bin/bash | ||
22 | +#!/usr/bin/env sh | ||
23 | set -e | ||
24 | |||
25 | DEVICE=$1 | ||
26 | diff --git a/src/helpers/udisks-helper-mdadm-expand b/src/helpers/udisks-helper-mdadm-expand | ||
27 | index 8b4e23d..921f96a 100755 | ||
28 | --- a/src/helpers/udisks-helper-mdadm-expand | ||
29 | +++ b/src/helpers/udisks-helper-mdadm-expand | ||
30 | @@ -1,4 +1,4 @@ | ||
31 | -#!/bin/bash | ||
32 | +#!/usr/bin/env sh | ||
33 | |||
34 | set -e | ||
35 | |||
36 | -- | ||
37 | 2.21.0 | ||
38 | |||
diff --git a/meta-oe/recipes-support/udisks/udisks_1.0.5.bb b/meta-oe/recipes-support/udisks/udisks_1.0.5.bb index 0373749f0f..0918fedda5 100644 --- a/meta-oe/recipes-support/udisks/udisks_1.0.5.bb +++ b/meta-oe/recipes-support/udisks/udisks_1.0.5.bb | |||
@@ -18,6 +18,7 @@ SRC_URI = "http://hal.freedesktop.org/releases/${BPN}-${PV}.tar.gz;name=${BPN} \ | |||
18 | file://0001-Make-udev-rules-directory-configurable.patch \ | 18 | file://0001-Make-udev-rules-directory-configurable.patch \ |
19 | file://0001-include-sys-sysmacros.h.patch \ | 19 | file://0001-include-sys-sysmacros.h.patch \ |
20 | file://0001-tools-Install-bash_completion-script-in-etc-bash_com.patch \ | 20 | file://0001-tools-Install-bash_completion-script-in-etc-bash_com.patch \ |
21 | file://0001-udisks-helper-Use-sh-interpreter-instead-of-bash.patch \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | SRC_URI[udisks.md5sum] = "70d48dcfe523a74cd7c7fbbc2847fcdd" | 24 | SRC_URI[udisks.md5sum] = "70d48dcfe523a74cd7c7fbbc2847fcdd" |