summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/udisks
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-10 21:46:42 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:06 +0200
commit14a5f1174c96f25c7dffc17902043f9be0e716f6 (patch)
treefe812b5d6f1adc62c9501d850d08fca4a052bfac /meta-oe/recipes-support/udisks
parentd1f914398dcfc1e0613007154b1515e7ffddc6d8 (diff)
downloadmeta-openembedded-14a5f1174c96f25c7dffc17902043f9be0e716f6.tar.gz
udisks: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-support/udisks')
-rw-r--r--meta-oe/recipes-support/udisks/udisks/add-systemd-support.patch112
-rw-r--r--meta-oe/recipes-support/udisks/udisks_1.0.4.bb10
2 files changed, 3 insertions, 119 deletions
diff --git a/meta-oe/recipes-support/udisks/udisks/add-systemd-support.patch b/meta-oe/recipes-support/udisks/udisks/add-systemd-support.patch
deleted file mode 100644
index 29df8a4da..000000000
--- a/meta-oe/recipes-support/udisks/udisks/add-systemd-support.patch
+++ /dev/null
@@ -1,112 +0,0 @@
1From 7a485d491697906b445020dfcb37fe91806d7134 Mon Sep 17 00:00:00 2001
2From: Lennart Poettering <lennart@poettering.net>
3Date: Thu, 22 Jul 2010 02:20:22 +0200
4Subject: [PATCH] systemd: install systemd unit files
5Upstream-Status: ?
6Based on: https://www.libreoffice.org/bugzilla/show_bug.cgi?id=29205
7---
8 Makefile.am | 5 ++++-
9 configure.ac | 9 +++++++++
10 data/.gitignore | 1 +
11 data/Makefile.am | 11 ++++++++++-
12 data/org.freedesktop.UDisks.service.in | 2 +-
13 data/udisks-daemon.service.in | 12 ++++++++++++
14 6 files changed, 37 insertions(+), 3 deletions(-)
15 create mode 100644 data/udisks-daemon.service.in
16
17diff --git a/Makefile.am b/Makefile.am
18index 588f05d..c3aaeea 100644
19--- a/Makefile.am
20+++ b/Makefile.am
21@@ -24,7 +24,10 @@ EXTRA_DIST = \
22 ChangeLog
23
24 # xsltproc barfs on 'make distcheck'; disable for now
25-DISTCHECK_CONFIGURE_FLAGS=--disable-man-pages --disable-gtk-doc
26+DISTCHECK_CONFIGURE_FLAGS = \
27+ --disable-man-pages \
28+ --disable-gtk-doc \
29+ --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
30
31 clean-local :
32 rm -f *~
33diff --git a/configure.ac b/configure.ac
34index a9141bf..39bbd7a 100644
35--- a/configure.ac
36+++ b/configure.ac
37@@ -232,6 +232,15 @@ AC_SUBST([GETTEXT_PACKAGE])
38 AM_GLIB_GNU_GETTEXT
39 AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[gettext domain])
40
41+# systemd
42+
43+AC_ARG_WITH([systemdsystemunitdir],
44+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
45+ [],
46+ [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
47+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
48+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
49+
50 AC_OUTPUT([
51 Makefile
52 data/Makefile
53diff --git a/data/Makefile.am b/data/Makefile.am
54index ca6d8ac..bf5c1a7 100644
55--- a/data/Makefile.am
56+++ b/data/Makefile.am
57@@ -35,6 +35,14 @@ avahiservicedir = $(sysconfdir)/avahi/services
58 avahiservice_DATA = udisks.service
59 endif # REMOTE_ACCESS_ENABLED
60
61+if HAVE_SYSTEMD
62+systemdsystemunit_DATA = \
63+ udisks-daemon.service
64+
65+udisks-daemon.service: udisks-daemon.service.in
66+ @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
67+endif
68+
69 EXTRA_DIST = \
70 80-udisks.rules \
71 $(dbusif_DATA) \
72@@ -42,7 +50,8 @@ EXTRA_DIST = \
73 $(dbusconf_in_files) \
74 udisks.pc.in \
75 udisks.service \
76+ udisks-daemon.service.in \
77 $(NULL)
78
79 clean-local :
80- rm -f *~ $(service_DATA) $(dbusconf_DATA)
81+ rm -f *~ $(service_DATA) $(dbusconf_DATA) udisks-daemon.service
82diff --git a/data/org.freedesktop.UDisks.service.in b/data/org.freedesktop.UDisks.service.in
83index b3606a6..6ba2cd0 100644
84--- a/data/org.freedesktop.UDisks.service.in
85+++ b/data/org.freedesktop.UDisks.service.in
86@@ -2,4 +2,4 @@
87 Name=org.freedesktop.UDisks
88 Exec=@libexecdir@/udisks-daemon
89 User=root
90-
91+SystemdService=udisks-daemon.service
92diff --git a/data/udisks-daemon.service.in b/data/udisks-daemon.service.in
93new file mode 100644
94index 0000000..78379b2
95--- /dev/null
96+++ b/data/udisks-daemon.service.in
97@@ -0,0 +1,12 @@
98+[Unit]
99+Description=Disk Manager
100+After=syslog.target
101+
102+[Service]
103+Type=dbus
104+BusName=org.freedesktop.UDisks
105+ExecStart=@libexecdir@/udisks-daemon
106+StandardOutput=syslog
107+
108+[Install]
109+WantedBy=graphical.target
110--
1111.7.0.1
112
diff --git a/meta-oe/recipes-support/udisks/udisks_1.0.4.bb b/meta-oe/recipes-support/udisks/udisks_1.0.4.bb
index 0018a5ffe..b6448ef13 100644
--- a/meta-oe/recipes-support/udisks/udisks_1.0.4.bb
+++ b/meta-oe/recipes-support/udisks/udisks_1.0.4.bb
@@ -2,22 +2,18 @@ DESCRIPTION = "A storage daemon that implements well-defined D-Bus interfaces th
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=73d83aebe7e4b62346afde80e0e94273" 3LIC_FILES_CHKSUM = "file://COPYING;md5=73d83aebe7e4b62346afde80e0e94273"
4 4
5DEPENDS = "libatasmart sg3-utils polkit udev dbus-glib glib-2.0 systemd" 5DEPENDS = "libatasmart sg3-utils polkit udev dbus-glib glib-2.0"
6# optional dependencies: device-mapper parted 6# optional dependencies: device-mapper parted
7 7
8SRC_URI = "http://hal.freedesktop.org/releases/${BPN}-${PV}.tar.gz;name=${BPN} \ 8SRC_URI = "http://hal.freedesktop.org/releases/${BPN}-${PV}.tar.gz;name=${BPN} \
9 file://add-systemd-support.patch \
10 file://optional-depends.patch" 9 file://optional-depends.patch"
11 10
12SRC_URI[udisks.md5sum] = "86c63b2b5484f2060499a052b5b6256b" 11SRC_URI[udisks.md5sum] = "86c63b2b5484f2060499a052b5b6256b"
13SRC_URI[udisks.sha256sum] = "854b89368733b9c3a577101b761ad5397ae75a05110c8698ac5b29de9a8bf8f5" 12SRC_URI[udisks.sha256sum] = "854b89368733b9c3a577101b761ad5397ae75a05110c8698ac5b29de9a8bf8f5"
14 13
15PR = "r4" 14PR = "r5"
16 15
17inherit autotools systemd 16inherit autotools
18
19SYSTEMD_PACKAGES = "${PN}-systemd"
20SYSTEMD_SERVICE_${PN}-systemd = "udisks-daemon.service"
21 17
22EXTRA_OECONF = "--disable-man-pages" 18EXTRA_OECONF = "--disable-man-pages"
23 19