summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/talloc/talloc_2.0.1.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/talloc/talloc_2.0.1.bb')
-rw-r--r--meta-oe/recipes-support/talloc/talloc_2.0.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
new file mode 100644
index 000000000..7bbfbc291
--- /dev/null
+++ b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://talloc.samba.org"
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://NEWS;md5=5fe776b23a711c9153ee94bc87e47334"
5
6inherit autotools pkgconfig
7
8SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz \
9 file://install-swig-interface-in-SWINGLIBDIR.patch \
10 file://sepbuild.patch \
11"
12SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b"
13SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4"
14
15TARGET_CC_ARCH += "${LDFLAGS}"
16
17PR = "r2"
18
19EXTRA_AUTORECONF = "--exclude=autopoint --exclude=aclocal"
20
21DEPENDS += "swig-native"
22
23do_install_prepend() {
24 # Hack the way swig interface for talloc is installed
25 # This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch
26 if which swig > /dev/null; then
27 SWIGLIBDIR="$(echo $(readlink -f $(swig -swiglib)) | \
28 sed -e 's#^${STAGING_DIR_NATIVE}##')"
29 fi
30 if [ -n "$SWIGLIBDIR" ]; then
31 export SWIGLIBDIR
32 else
33 echo "No swig found"
34 fi
35}
36
37do_install_append() {
38 install -d ${D}${libdir}
39 ln -s libtalloc.so.2.0.1 ${D}${libdir}/libtalloc.so.2.0
40 ln -s libtalloc.so.2.0 ${D}${libdir}/libtalloc.so.2
41 ln -s libtalloc.so.2 ${D}${libdir}/libtalloc.so
42}
43
44PACKAGES += "${PN}-swig"
45FILES_${PN}-swig += "${datadir}"