summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/srecord/files
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2017-06-05 13:25:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:45 +0200
commitda5beadf988452baecee72daf16f46ea83661b2d (patch)
treef10e9e7a076bfd71054baa38b05aaf17332b98b0 /meta-oe/recipes-support/srecord/files
parent3b80f0cb3b0e3b5a9f58c1bfb7ae45f4d0e7a673 (diff)
downloadmeta-openembedded-da5beadf988452baecee72daf16f46ea83661b2d.tar.gz
srecord: add collection of tools for manipulating EPROM load files
This collection of tools is used for EPROM data manipulation. More info could be found on page: http://srecord.sourceforge.net/ Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/srecord/files')
-rw-r--r--meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch b/meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch
new file mode 100644
index 000000000..9b2bd9979
--- /dev/null
+++ b/meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch
@@ -0,0 +1,57 @@
1Add option to build this utility without a documentation.
2
3For full documentation building are necessary utilities like
4groff and ps2pdf. Full documentation can takes a lot of space.
5So it can be disabled by overloading makefile variable WITHOUT_DOC.
6
7Upstream-Status: Inappropriate [Other]
8Workaround specific to our build system.
9
10Signed-off-by: Andrej Valek <andrej.valek@siemens.com>
11
12diff --git a/Makefile.in b/Makefile.in
13index 9bdd8f1..a2b5494 100644
14--- a/Makefile.in
15+++ b/Makefile.in
16@@ -141,6 +141,14 @@ GROFF = @GROFF@
17 #
18 SOELIM = @SOELIM@
19
20+# Option to build this utility without building and installing the documentation.
21+WITHOUT_DOC ?= 0
22+ifeq ($(WITHOUT_DOC),0)
23+ BUILD_DOC = all-doc
24+ INST_DOC = install-doc
25+ CLR_DOC = clean-doc
26+endif
27+
28 # ---------------------------------------------------------
29 # You should not need to change anything below this line.
30
31@@ -4090,7 +4098,7 @@ bin/test_url_decode: $(test_url_decode_obj) .bin srecord/libsrecord.la
32 $(LIBTOOL) --mode=link --tag=CXX $(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ \
33 $(test_url_decode_obj) srecord/libsrecord.la $(LDFLAGS) $(LIBS)
34
35-all: all-bin all-doc
36+all: all-bin $(BUILD_DOC)
37
38 all-bin: bin/srec_cat bin/srec_cmp bin/srec_info bin/test_arglex_ambiguous \
39 bin/test_crc16 bin/test_fletcher16 bin/test_gecos \
40@@ -4156,7 +4164,7 @@ test_files = t0001a t0002a t0003a t0004a t0005a t0006a t0007a t0008a t0009a \
41 sure: $(test_files)
42 @echo Passed All Tests
43
44-clean: clean-bin clean-doc clean-misc clean-obj
45+clean: clean-bin $(CLR_DOC) clean-misc clean-obj
46
47 clean-bin:
48 rm -f bin/srec_cat bin/srec_cmp bin/srec_info bin/test_arglex_ambiguous
49@@ -4443,7 +4451,7 @@ distclean-directories:
50 rm -rf test/fletcher16/.libs test/gecos/.libs test/hyphen/.libs
51 rm -rf test/url_decode/.libs
52
53-install: install-bin install-doc install-include install-libdir install-man
54+install: install-bin $(INST_DOC) install-include install-libdir install-man
55
56 install-bin: $(bindir)/srec_cat $(bindir)/srec_cmp $(bindir)/srec_info
57