summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/satyr/satyr_0.27.bb
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-11-27 17:39:09 +0800
committerKhem Raj <raj.khem@gmail.com>2018-11-28 21:48:21 -0800
commit5dbdf76bb783e7dd78c8df5801c53069a1716e83 (patch)
tree064d24924cbe3861ca18ffa66e9dc23695cd11d7 /meta-oe/recipes-support/satyr/satyr_0.27.bb
parent3fa7f4bbe27586ad1f7459993128e6315914774c (diff)
downloadmeta-openembedded-5dbdf76bb783e7dd78c8df5801c53069a1716e83.tar.gz
satyr: upgrade to 0.27
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/satyr/satyr_0.27.bb')
-rw-r--r--meta-oe/recipes-support/satyr/satyr_0.27.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/satyr/satyr_0.27.bb b/meta-oe/recipes-support/satyr/satyr_0.27.bb
new file mode 100644
index 000000000..10dfc2bad
--- /dev/null
+++ b/meta-oe/recipes-support/satyr/satyr_0.27.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
6LICENSE = "GPLv2"
7
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
12"
13SRCREV = "dff1b877d42bf2153f8f090905d9cc8fb333bf1e"
14S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
17
18DEPENDS += " \
19 gdb \
20"
21
22PACKAGES += "python3-${PN}"
23FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
24
25PACKAGECONFIG ??= "python3 rpm"
26PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
27PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
28PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
29
30do_configure_prepend() {
31 ${S}/gen-version
32}