summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 13:24:47 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 14:43:41 +0200
commit89500c583e0f1dc1b4ffdf72914e08e505e427e0 (patch)
treeb073036cc61aa34ca5ac9eec4d617366e0dcb3d5 /meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
parente66079da37992abd54486488aa06a99bf7a4198c (diff)
downloadmeta-openembedded-89500c583e0f1dc1b4ffdf72914e08e505e427e0.tar.gz
recipes,classes: import a lot of recipes from meta-shr
* tested on shr-lite-image for om-gta02 and nokia900 (with meta-shr layer)
Diffstat (limited to 'meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb')
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
new file mode 100644
index 000000000..f8ca7947f
--- /dev/null
+++ b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A user-space tool to show and modify the state of GPIOs on the S3c64xx platform"
2SECTION = "console/utils"
3AUTHOR = "Werner Almesberger <werner@openmoko.org>"
4LICENSE = "GPL"
5SRCREV = "4949"
6PV = "1.0+svnr${SRCPV}"
7PR = "r0"
8
9SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;proto=http"
10S = "${WORKDIR}/gpio"
11
12do_compile() {
13 ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio-s3c6410.c
14}
15
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 ${PN} ${D}${sbindir}
19}