summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler/poppler_0.86.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-03-30 02:26:56 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-30 22:02:13 -0700
commit096db172f547a3ef8ac1187da9876c3db611e80e (patch)
treedd0ac5c1141852230fd78fe67153be11f5f3ae05 /meta-oe/recipes-support/poppler/poppler_0.86.1.bb
parent9e58e66a8b7193075cb474964a31a7f466b78e4a (diff)
downloadmeta-openembedded-096db172f547a3ef8ac1187da9876c3db611e80e.tar.gz
poppler: upgrade 0.85.0 -> 0.86.1
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/poppler/poppler_0.86.1.bb')
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.86.1.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_0.86.1.bb b/meta-oe/recipes-support/poppler/poppler_0.86.1.bb
new file mode 100644
index 000000000..96006dc8d
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler_0.86.1.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
2HOMEPAGE = "https://poppler.freedesktop.org/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
7 file://0001-Do-not-overwrite-all-our-build-flags.patch \
8 file://basename-include.patch \
9 "
10SRC_URI[md5sum] = "2a638739f29e82a0a57b633ea39c87f3"
11SRC_URI[sha256sum] = "af630a277c8e194c31339c5446241834aed6ed3d4b4dc7080311e51c66257f6c"
12
13DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
14
15inherit cmake pkgconfig gobject-introspection
16
17PACKAGECONFIG ??= "jpeg openjpeg png tiff nss ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}"
18PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg"
19PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng"
20PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff"
21PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
22PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
23PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
24PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss"
25
26# surprise - did not expect this to work :)
27inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
28
29SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
30
31EXTRA_OECMAKE += " \
32 -DENABLE_CMS=lcms2 \
33 -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
34 -DBUILD_GTK_TESTS=OFF \
35 -DENABLE_ZLIB=ON \
36 -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
37 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \
38"
39
40do_configure_append() {
41 # poppler macro uses pkg-config to check for g-ir runtimes. Something
42 # makes them point to /usr/bin. Align them to sysroot - that's where the
43 # gir-wrappers are:
44 sed -i 's: ${bindir}/g-ir: ${STAGING_BINDIR}/g-ir:' ${B}/build.ninja
45}
46
47PACKAGES =+ "libpoppler libpoppler-glib"
48FILES_libpoppler = "${libdir}/libpoppler.so.*"
49FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
50
51RDEPENDS_libpoppler = "poppler-data"