summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poco/poco_1.9.0.bb
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2018-05-24 14:26:49 -0400
committerKhem Raj <raj.khem@gmail.com>2018-05-29 12:56:19 -0700
commit2d07e06ce9cf2c6b9dfb339e396514bf7a351bdd (patch)
tree28c0104e6f2f13258ec0bba00795c27280ed1e5f /meta-oe/recipes-support/poco/poco_1.9.0.bb
parent4b9e0f546e024680d7897d06037fa79c78058c3c (diff)
downloadmeta-openembedded-2d07e06ce9cf2c6b9dfb339e396514bf7a351bdd.tar.gz
poco: variable cleanup
Reorder recipe variables according to: https://www.openembedded.org/wiki/Styleguide Originally-conceived-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/poco/poco_1.9.0.bb')
-rw-r--r--meta-oe/recipes-support/poco/poco_1.9.0.bb44
1 files changed, 22 insertions, 22 deletions
diff --git a/meta-oe/recipes-support/poco/poco_1.9.0.bb b/meta-oe/recipes-support/poco/poco_1.9.0.bb
index 1016caef7..a4f8a0518 100644
--- a/meta-oe/recipes-support/poco/poco_1.9.0.bb
+++ b/meta-oe/recipes-support/poco/poco_1.9.0.bb
@@ -1,34 +1,22 @@
1SUMMARY = "Modern, powerful open source cross-platform C++ class libraries" 1SUMMARY = "Modern, powerful open source cross-platform C++ class libraries"
2DESCRIPTION = "Modern, powerful open source C++ class libraries and frameworks for building network- and internet-based applications that run on desktop, server, mobile and embedded systems." 2DESCRIPTION = "Modern, powerful open source C++ class libraries and frameworks for building network- and internet-based applications that run on desktop, server, mobile and embedded systems."
3SECTION = "libs"
4HOMEPAGE = "http://pocoproject.org/" 3HOMEPAGE = "http://pocoproject.org/"
4SECTION = "libs"
5LICENSE = "BSL-1.0" 5LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4267f48fc738f50380cbeeb76f95cebc" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=4267f48fc738f50380cbeeb76f95cebc"
7 7
8# These dependencies are required by Foundation 8# These dependencies are required by Foundation
9DEPENDS = "libpcre zlib" 9DEPENDS = "libpcre zlib"
10 10
11inherit cmake ptest
12
13BBCLASSEXTEND = "native"
14
15SRCREV = "94966785a8f9ad0191dffd075ebd67826e6e4b6d"
16SRC_URI = " \ 11SRC_URI = " \
17 git://github.com/pocoproject/poco.git \ 12 git://github.com/pocoproject/poco.git \
18 file://run-ptest \ 13 file://run-ptest \
19 " 14 "
15SRCREV = "94966785a8f9ad0191dffd075ebd67826e6e4b6d"
20 16
21S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
22 18
23EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=RelWithDebInfo -DPOCO_UNBUNDLED=ON \ 19inherit cmake ptest
24 -DZLIB_LIBRARY_RELEASE:STRING=z -DPCRE_LIBRARY:STRING=pcre \
25 ${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_TESTS=ON ', '', d)}"
26
27# For the native build we want to use the bundled version
28EXTRA_OECMAKE_append_class-native = " -DPOCO_UNBUNDLED=OFF"
29
30# do not use rpath
31EXTRA_OECMAKE_append = " -DCMAKE_SKIP_RPATH=ON"
32 20
33# By default the most commonly used poco components are built 21# By default the most commonly used poco components are built
34# Foundation is built anyway and doesn't need to be listed explicitly 22# Foundation is built anyway and doesn't need to be listed explicitly
@@ -60,6 +48,16 @@ PACKAGECONFIG[PageCompiler] = "-DENABLE_PAGECOMPILER=ON,-DENABLE_PAGECOMPILER=OF
60PACKAGECONFIG[PageCompilerFile2Page] = "-DENABLE_PAGECOMPILER_FILE2PAGE=ON,-DENABLE_PAGECOMPILER_FILE2PAGE=OFF" 48PACKAGECONFIG[PageCompilerFile2Page] = "-DENABLE_PAGECOMPILER_FILE2PAGE=ON,-DENABLE_PAGECOMPILER_FILE2PAGE=OFF"
61PACKAGECONFIG[SevenZip] = "-DENABLE_SEVENZIP=ON,-DENABLE_SEVENZIP=OFF" 49PACKAGECONFIG[SevenZip] = "-DENABLE_SEVENZIP=ON,-DENABLE_SEVENZIP=OFF"
62 50
51EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=RelWithDebInfo -DPOCO_UNBUNDLED=ON \
52 -DZLIB_LIBRARY_RELEASE:STRING=z -DPCRE_LIBRARY:STRING=pcre \
53 ${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_TESTS=ON ', '', d)}"
54
55# For the native build we want to use the bundled version
56EXTRA_OECMAKE_append_class-native = " -DPOCO_UNBUNDLED=OFF"
57
58# do not use rpath
59EXTRA_OECMAKE_append = " -DCMAKE_SKIP_RPATH=ON"
60
63python populate_packages_prepend () { 61python populate_packages_prepend () {
64 poco_libdir = d.expand('${libdir}') 62 poco_libdir = d.expand('${libdir}')
65 pn = d.getVar("PN") 63 pn = d.getVar("PN")
@@ -77,6 +75,14 @@ python populate_packages_prepend () {
77 d.setVar("POCO_TESTRUNNERS", "\n".join(testrunners)) 75 d.setVar("POCO_TESTRUNNERS", "\n".join(testrunners))
78} 76}
79 77
78do_install_ptest () {
79 cp -rf ${B}/bin/ ${D}${PTEST_PATH}
80 cp -f ${B}/lib/libCppUnit.so* ${D}${libdir}
81 cp -rf ${B}/*/testsuite/data ${D}${PTEST_PATH}/bin/
82 find "${D}${PTEST_PATH}" -executable -exec chrpath -d {} \;
83 echo "${POCO_TESTRUNNERS}" > "${D}${PTEST_PATH}/testrunners"
84}
85
80PACKAGES_DYNAMIC = "poco-.*" 86PACKAGES_DYNAMIC = "poco-.*"
81 87
82# "poco" is a metapackage which pulls in all Poco components 88# "poco" is a metapackage which pulls in all Poco components
@@ -89,10 +95,4 @@ ALLOW_EMPTY_${PN}-cppunit = "1"
89 95
90RDEPENDS_${PN}-ptest += "${PN}-cppunit" 96RDEPENDS_${PN}-ptest += "${PN}-cppunit"
91 97
92do_install_ptest () { 98BBCLASSEXTEND = "native"
93 cp -rf ${B}/bin/ ${D}${PTEST_PATH}
94 cp -f ${B}/lib/libCppUnit.so* ${D}${libdir}
95 cp -rf ${B}/*/testsuite/data ${D}${PTEST_PATH}/bin/
96 find "${D}${PTEST_PATH}" -executable -exec chrpath -d {} \;
97 echo "${POCO_TESTRUNNERS}" > "${D}${PTEST_PATH}/testrunners"
98}