summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/p910nd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-01 21:58:02 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-01 23:20:22 -0700
commitd6e59649ffea462899144748540c059ad8753240 (patch)
tree42d01f55fb7a8e0f9e7f36a2faf0607be072f0e1 /meta-oe/recipes-support/p910nd
parentedf94a6e8dd8d5c6942790488a501e0e4c628b20 (diff)
downloadmeta-openembedded-d6e59649ffea462899144748540c059ad8753240.tar.gz
p910nd: Switch to using github for SRC_URI
This is new location where the project is developed now. Pass CFLAGS to compiler cmdline Package init script Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/p910nd')
-rw-r--r--meta-oe/recipes-support/p910nd/p910nd_0.97.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/p910nd/p910nd_0.97.bb b/meta-oe/recipes-support/p910nd/p910nd_0.97.bb
index a27edb1410..cd7f79ea60 100644
--- a/meta-oe/recipes-support/p910nd/p910nd_0.97.bb
+++ b/meta-oe/recipes-support/p910nd/p910nd_0.97.bb
@@ -2,21 +2,28 @@ DESCRIPTION = "A small network printer daemon for embedded situations that passe
2HOMEPAGE = "http://p910nd.sourceforge.net/" 2HOMEPAGE = "http://p910nd.sourceforge.net/"
3SECTION = "console/utils" 3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only" 4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" 5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3d82780e8917b360cbee7b9ec3e40734"
6 6
7PR = "r2" 7PR = "r2"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/p910nd/p910nd-${PV}.tar.bz2 \ 9# v0.97
10SRCREV = "57ebc07ad8723ea4106090536c58c7f7160743e2"
11SRC_URI = "git://github.com/kenyapcomau/p910nd;protocol=https;branch=master \
10 file://fix-var-lock.patch" 12 file://fix-var-lock.patch"
11 13
12SRC_URI[md5sum] = "69461a6c54dca0b13ecad5b83864b43e" 14S = "${WORKDIR}/git"
13SRC_URI[sha256sum] = "4ac980a3ae24babae6f70f0a692625ece03a4a92c357fbb10d2e368386c3c26f" 15
16inherit update-rc.d
17
18INITSCRIPT_NAME = "p910nd"
19INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
14 20
15do_compile () { 21do_compile () {
16 ${CC} ${LDFLAGS} -o p910nd p910nd.c 22 ${CC} ${CFLAGS} ${LDFLAGS} -o p910nd p910nd.c
17} 23}
18 24
19do_install () { 25do_install () {
20 install -D -m 0755 ${S}/p910nd ${D}${sbindir}/p910nd 26 install -D -m 0755 ${S}/p910nd ${D}${sbindir}/p910nd
21 install -D -m 0644 ${S}/p910nd.conf ${D}${sysconfdir}/p910nd.conf 27 install -D -m 0644 ${S}/aux/p910nd.conf ${D}${sysconfdir}/sysconfig/p910nd.conf
28 install -D -m 0644 ${S}/aux/p910nd.init ${D}${sysconfdir}/init.d/p910nd
22} 29}