summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openldap
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-10-08 01:01:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-10 12:47:35 +0200
commita4bdcbdbca05bbb4a452e06982038f0a38bcb91f (patch)
tree9bc991841384de9d1c601421db38f1e66de65dee /meta-oe/recipes-support/openldap
parent95d7606c6706a6bae9814879eb5640ae70166c86 (diff)
downloadmeta-openembedded-a4bdcbdbca05bbb4a452e06982038f0a38bcb91f.tar.gz
openldap: use PN for PACKAGES_DYNAMIC
Fixed do_packagedata error when multilib: ERROR: The recipe openldap is trying to install files into a shared area when those files already exist. Those files and their manifest location are: /path/to/sysroots/qemux86-64/pkgdata/runtime-rprovides/openldap-backends/openldap-backends Matched in manifest-qemux86-64-lib32-openldap.packagedata /path/to/tmp/sysroots/qemux86-64/pkgdata/runtime/openldap-backends.packaged Matched in manifest-qemux86-64-lib32-openldap.packagedata /path/to/tmp/sysroots/qemux86-64/pkgdata/runtime/openldap-backends Matched in manifest-qemux86-64-lib32-openldap.packagedata Please verify which recipe should provide the above files. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-oe/recipes-support/openldap')
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.39.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.39.bb b/meta-oe/recipes-support/openldap/openldap_2.4.39.bb
index 243e38f39..8752395fa 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.39.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.39.bb
@@ -195,13 +195,13 @@ INITSCRIPT_PACKAGES = "${PN}-slapd"
195INITSCRIPT_NAME_${PN}-slapd = "openldap" 195INITSCRIPT_NAME_${PN}-slapd = "openldap"
196INITSCRIPT_PARAMS_${PN}-slapd = "defaults" 196INITSCRIPT_PARAMS_${PN}-slapd = "defaults"
197 197
198PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*" 198PACKAGES_DYNAMIC += "^${PN}-backends.* ^${PN}-backend-.*"
199 199
200python populate_packages_prepend () { 200python populate_packages_prepend () {
201 backend_dir = d.expand('${libexecdir}/openldap') 201 backend_dir = d.expand('${libexecdir}/openldap')
202 do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True) 202 do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True)
203 203
204 metapkg = "openldap-backends" 204 metapkg = "${PN}-backends"
205 d.setVar('ALLOW_EMPTY_' + metapkg, "1") 205 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
206 d.setVar('FILES_' + metapkg, "") 206 d.setVar('FILES_' + metapkg, "")
207 metapkg_rdepends = [] 207 metapkg_rdepends = []