summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-06-18 16:08:55 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-18 07:18:29 -0700
commita52e374663ed92e73981251ade7a6cc5357c9c70 (patch)
treec21ecaf81c65b9b4d9bcb7e2b9ad10eab7236cf4 /meta-oe/recipes-support/opencv
parent358b3982583c93fdc0a4cebdab31f923d77b7f8b (diff)
downloadmeta-openembedded-a52e374663ed92e73981251ade7a6cc5357c9c70.tar.gz
opencv: make ts module external
* Remove the patch which used to create ts module as shared library as the logic is covered in the new added patch which makes ts module external * Add a patch to make ts module external to fix the below broken link: # ls -l /usr/lib64/libopencv_ts.so lrwxrwxrwx 1 root root 19 Jun 14 19:13 /usr/lib64/libopencv_ts.so -> libopencv_ts.so.4.3 # rpm -qf /usr/lib64/libopencv_ts.so libopencv-ts-dev-4.3.0-r0.corei7_64 # readlink -e /usr/lib64/libopencv_ts.so # echo $? 1 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv')
-rw-r--r--meta-oe/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch42
-rw-r--r--meta-oe/recipes-support/opencv/opencv/0002-Make-opencv-ts-create-share-library-intead-of-static.patch24
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.3.0.bb2
3 files changed, 43 insertions, 25 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch b/meta-oe/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch
new file mode 100644
index 000000000..d56b8ae67
--- /dev/null
+++ b/meta-oe/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch
@@ -0,0 +1,42 @@
1From 11bbf909e08594628bd757d989ae34cf1bfe200b Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 18 Jun 2020 05:51:38 +0000
4Subject: [PATCH] Make ts module external
5
6Make ts module external
7
8Reference: https://github.com/qbonnard/opencv/commit/6b229c5834cb9a0930425e762a6c7b03244d7abb
9
10Upstream-Status: Submitted [https://github.com/opencv/opencv/issues/8408]
11
12Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
13---
14 modules/ts/CMakeLists.txt | 5 +----
15 1 file changed, 1 insertion(+), 4 deletions(-)
16
17diff --git a/modules/ts/CMakeLists.txt b/modules/ts/CMakeLists.txt
18index f95bed0793..66f315bcca 100644
19--- a/modules/ts/CMakeLists.txt
20+++ b/modules/ts/CMakeLists.txt
21@@ -4,9 +4,6 @@ if(NOT BUILD_opencv_ts AND NOT BUILD_TESTS AND NOT BUILD_PERF_TESTS)
22 ocv_module_disable(ts)
23 endif()
24
25-set(OPENCV_MODULE_TYPE STATIC)
26-set(OPENCV_MODULE_IS_PART_OF_WORLD FALSE)
27-
28 if(WINRT)
29 # WINRT doesn't have access to environment variables
30 # so adding corresponding macros during CMake run
31@@ -16,7 +13,7 @@ endif()
32
33 ocv_warnings_disable(CMAKE_CXX_FLAGS -Wundef)
34
35-ocv_add_module(ts INTERNAL opencv_core opencv_imgproc opencv_imgcodecs opencv_videoio opencv_highgui)
36+ocv_add_module(ts opencv_core opencv_imgproc opencv_imgcodecs opencv_videoio opencv_highgui)
37
38 ocv_glob_module_sources()
39 ocv_module_include_directories()
40--
412.24.1
42
diff --git a/meta-oe/recipes-support/opencv/opencv/0002-Make-opencv-ts-create-share-library-intead-of-static.patch b/meta-oe/recipes-support/opencv/opencv/0002-Make-opencv-ts-create-share-library-intead-of-static.patch
deleted file mode 100644
index 20d54d407..000000000
--- a/meta-oe/recipes-support/opencv/opencv/0002-Make-opencv-ts-create-share-library-intead-of-static.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1From 78e2fc167fd27ab17175dcfd6eccf6f74bd5e1c7 Mon Sep 17 00:00:00 2001
2From: Bian Naimeng <biannm@cn.fujitsu.com>
3Date: Wed, 19 Apr 2017 03:11:37 +0900
4Subject: [PATCH] Make opencv-ts create share library intead of static.
5
6Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
7
8---
9 modules/ts/CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/modules/ts/CMakeLists.txt b/modules/ts/CMakeLists.txt
13index f95bed0793..ee67858df8 100644
14--- a/modules/ts/CMakeLists.txt
15+++ b/modules/ts/CMakeLists.txt
16@@ -4,7 +4,7 @@ if(NOT BUILD_opencv_ts AND NOT BUILD_TESTS AND NOT BUILD_PERF_TESTS)
17 ocv_module_disable(ts)
18 endif()
19
20-set(OPENCV_MODULE_TYPE STATIC)
21+#set(OPENCV_MODULE_TYPE STATIC)
22 set(OPENCV_MODULE_IS_PART_OF_WORLD FALSE)
23
24 if(WINRT)
diff --git a/meta-oe/recipes-support/opencv/opencv_4.3.0.bb b/meta-oe/recipes-support/opencv/opencv_4.3.0.bb
index 2587b189c..7927ce25f 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.3.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.3.0.bb
@@ -44,11 +44,11 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \
44 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_vgg_20160317;destsuffix=vgg;name=vgg \ 44 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_vgg_20160317;destsuffix=vgg;name=vgg \
45 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_face_alignment_20170818;destsuffix=face;name=face \ 45 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_face_alignment_20170818;destsuffix=face;name=face \
46 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \ 46 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
47 file://0002-Make-opencv-ts-create-share-library-intead-of-static.patch \
48 file://0003-To-fix-errors-as-following.patch \ 47 file://0003-To-fix-errors-as-following.patch \
49 file://0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch \ 48 file://0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch \
50 file://0001-Dont-use-isystem.patch \ 49 file://0001-Dont-use-isystem.patch \
51 file://download.patch \ 50 file://download.patch \
51 file://0001-Make-ts-module-external.patch \
52 " 52 "
53PV = "4.3.0" 53PV = "4.3.0"
54 54