summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv/opencv_3.2.bb
diff options
context:
space:
mode:
authorIsmo Puustinen <ismo.puustinen@intel.com>2017-05-24 16:30:39 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:46 +0200
commite76a3913769a9e49321ff7018e868ebfdc78b788 (patch)
tree7e020a48f758362e4e3513c20d0a4840e6c0de10 /meta-oe/recipes-support/opencv/opencv_3.2.bb
parent8274d5ab5b32c9015ffd79381bf4711c947b63d0 (diff)
downloadmeta-openembedded-e76a3913769a9e49321ff7018e868ebfdc78b788.tar.gz
opencv: fix building with PACKAGECONFIG "dnn" enabled.
Dependency "lapack" isn't available in meta-openembedded and it doesn't cause a build error, so drop it. Fix buidling dnn module by backporting a patch from opencv-contrib. Signed-off-by: Ismo Puustinen <ismo.puustinen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv/opencv_3.2.bb')
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.2.bb b/meta-oe/recipes-support/opencv/opencv_3.2.bb
index b6db37dd8..535c761fa 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.2.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.2.bb
@@ -31,6 +31,7 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \
31 file://0002-Revert-check-FP16-build-condition-correctly.patch \ 31 file://0002-Revert-check-FP16-build-condition-correctly.patch \
32 file://0001-Make-opencv-ts-create-share-library-intead-of-static.patch \ 32 file://0001-Make-opencv-ts-create-share-library-intead-of-static.patch \
33 file://0001-To-fix-errors-as-following.patch \ 33 file://0001-To-fix-errors-as-following.patch \
34 file://0001-tracking-make-opencv_dnn-dependancy-optional.patch;patchdir=../contrib/ \
34" 35"
35 36
36PV = "3.2+git${SRCPV}" 37PV = "3.2+git${SRCPV}"
@@ -63,7 +64,7 @@ PACKAGECONFIG ??= "python3 eigen jpeg png tiff v4l libv4l gstreamer samples tbb
63 64
64PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas," 65PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas,"
65PACKAGECONFIG[amdfft] = "-DWITH_OPENCLAMDFFT=ON,-DWITH_OPENCLAMDFFT=OFF,libclamdfft," 66PACKAGECONFIG[amdfft] = "-DWITH_OPENCLAMDFFT=ON,-DWITH_OPENCLAMDFFT=OFF,libclamdfft,"
66PACKAGECONFIG[dnn] = "-DBUILD_opencv_dnn=ON -DUPDATE_PROTO_FILES=ON -DBUILD_PROTOBUF=OFF,-DBUILD_opencv_dnn=OFF,lapack protobuf protobuf-native," 67PACKAGECONFIG[dnn] = "-DBUILD_opencv_dnn=ON -DUPDATE_PROTO_FILES=ON -DBUILD_PROTOBUF=OFF,-DBUILD_opencv_dnn=OFF,protobuf protobuf-native,"
67PACKAGECONFIG[eigen] = "-DWITH_EIGEN=ON,-DWITH_EIGEN=OFF,libeigen gflags glog," 68PACKAGECONFIG[eigen] = "-DWITH_EIGEN=ON,-DWITH_EIGEN=OFF,libeigen gflags glog,"
68PACKAGECONFIG[freetype] = "-DBUILD_opencv_freetype=ON,-DBUILD_opencv_freetype=OFF,freetype," 69PACKAGECONFIG[freetype] = "-DBUILD_opencv_freetype=ON,-DBUILD_opencv_freetype=OFF,freetype,"
69PACKAGECONFIG[gphoto2] = "-DWITH_GPHOTO2=ON,-DWITH_GPHOTO2=OFF,libgphoto2," 70PACKAGECONFIG[gphoto2] = "-DWITH_GPHOTO2=ON,-DWITH_GPHOTO2=OFF,libgphoto2,"