summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-22 20:05:35 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-23 13:29:20 -0800
commit5f063ad3b633d7bc990872453c23233846366a89 (patch)
tree4aec5c9210a56691982700e303c37813088220e5 /meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
parent55f2541bf6279a3aa14eb1597e3a4bf844c7b00f (diff)
downloadmeta-openembedded-5f063ad3b633d7bc990872453c23233846366a89.tar.gz
open-vm-tools: Upgrade to 10.3.5
Add a patch to fix build with gcc9 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb105
1 files changed, 0 insertions, 105 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
deleted file mode 100644
index 2d7486da3..000000000
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
+++ /dev/null
@@ -1,105 +0,0 @@
1# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14SECTION = "vmware-tools"
15
16LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac"
18LICENSE_modules/freebsd/vmblock = "BSD"
19LICENSE_modules/freebsd/vmmemctl = "GPL-2.0"
20LICENSE_modules/freebsd/vmxnet = "GPL-2.0"
21LICENSE_modules/linux = "GPL-2.0"
22LICENSE_modules/solaris = "CDDL-1.0"
23
24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
25 file://tools.conf \
26 file://vmtoolsd.service \
27 file://vmtoolsd.init \
28 file://0001-configure.ac-don-t-use-dnet-config.patch \
29 file://0002-add-include-sys-sysmacros.h.patch \
30 file://0005-Use-configure-test-for-struct-timespec.patch \
31 file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \
32 file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \
33 file://0011-Use-configure-test-for-sys-stat.h-include.patch \
34 file://fix-subdir-objects-configure-error.patch \
35 file://0001-include-poll.h-instead-of-sys-poll.h.patch \
36 file://0002-Rename-poll.h-to-vm_poll.h.patch \
37 file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \
38 file://0004-Use-uintmax_t-for-handling-rlim_t.patch \
39 file://0001-Use-off64_t-instead-of-__off64_t.patch \
40"
41SRCREV = "2147df6aabe639fc5ff423ed791a8e7f02bf8d0a"
42
43S = "${WORKDIR}/git/open-vm-tools"
44
45DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps libtirpc"
46
47# open-vm-tools is supported only on x86.
48COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
49
50inherit autotools pkgconfig systemd update-rc.d
51
52SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
53
54EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
55 --disable-tests --without-gtkmm --without-xerces --without-pam \
56 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
57 --without-root-privileges --without-kernel-modules"
58
59NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
60X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
61PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
62
63# fuse gets implicitly detected; there is no --without-fuse option.
64PACKAGECONFIG[fuse] = ",,fuse"
65
66CFLAGS_append_toolchain-clang = " -Wno-address-of-packed-member"
67FILES_${PN} += "\
68 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
69 ${libdir}/open-vm-tools/plugins/common/lib*.so \
70 ${sysconfdir}/vmware-tools/tools.conf \
71"
72FILES_${PN}-locale += "${datadir}/open-vm-tools/messages"
73FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
74
75CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
76
77RDEPENDS_${PN} = "util-linux libdnet fuse"
78
79do_install_append() {
80 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
81 install -d ${D}${sysconfdir}/vmware-tools
82 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
83 install -d ${D}${systemd_unitdir}/system
84 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
85 else
86 install -d ${D}${sysconfdir}/init.d
87 install -m 0755 ${WORKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd
88 fi
89 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
90}
91
92do_configure_prepend() {
93 export CUSTOM_DNET_NAME=dnet
94 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
95}
96
97INITSCRIPT_PACKAGES = "${PN}"
98INITSCRIPT_NAME_${PN} = "vmtoolsd"
99INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
100
101python() {
102 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
103 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
104 raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
105}