summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ode
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-02-24 13:59:25 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-05 18:38:39 +0100
commit3349d31304790b4122886c4843ef3ee9e20c9191 (patch)
treee3e160e58a16220332375c064d8190852e64f850 /meta-oe/recipes-support/ode
parent840a60cb1d41199c57d87e820abd88b40c7c8ae4 (diff)
downloadmeta-openembedded-3349d31304790b4122886c4843ef3ee9e20c9191.tar.gz
ode: upgrade to 0.13
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/ode')
-rw-r--r--meta-oe/recipes-support/ode/ode_0.13.bb27
-rw-r--r--meta-oe/recipes-support/ode/ode_0.9.bb28
2 files changed, 27 insertions, 28 deletions
diff --git a/meta-oe/recipes-support/ode/ode_0.13.bb b/meta-oe/recipes-support/ode/ode_0.13.bb
new file mode 100644
index 000000000..8e9eb153c
--- /dev/null
+++ b/meta-oe/recipes-support/ode/ode_0.13.bb
@@ -0,0 +1,27 @@
1SUMMARY = "ODE is an Open Source Physics Engine"
2SECTION = "libs"
3HOMEPAGE = "http://www.ode.org"
4LICENSE = "LGPLv2.1 & BSD"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=1de906ee96808d9776dd72a5f9a79a22 \
7 file://LICENSE.TXT;md5=771782cb6245c7fbbe74bc0ec059beff \
8"
9# LICENSE-BSD.TXT is missing in 0.13 tarball, but COPYING still says it's dual licensed
10# and svn repo still contains LICENSE-BSD.TXT so maybe it will return in next tarball
11# file://LICENSE-BSD.TXT;md5=c74e6304a772117e059458fb9763a928
12
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-${PV}.tar.bz2"
15SRC_URI[md5sum] = "04b32c9645c147e18caff7a597a19f84"
16SRC_URI[sha256sum] = "34ce3e236e313bf109a0cb5546d2fca462aed99f29a42e62bc1463b803c31ef9"
17
18inherit autotools binconfig
19
20EXTRA_OECONF = "--disable-demos --enable-soname"
21
22FILES_${PN} = "${libdir}/lib*${SOLIBS}"
23
24PACKAGECONFIG ?= ""
25# if it isn't explicitly selected and "$build_os" == "$target_os", then configure will run
26# series of AC_TRY_RUN which won't work for cross-compilation and configure fails
27PACKAGECONFIG[double-precision] = "--enable-double-precision,--disable-double-precision"
diff --git a/meta-oe/recipes-support/ode/ode_0.9.bb b/meta-oe/recipes-support/ode/ode_0.9.bb
deleted file mode 100644
index 8b9955e39..000000000
--- a/meta-oe/recipes-support/ode/ode_0.9.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1SUMMARY = "ODE is an Open Source Physics Engine"
2SECTION = "libs"
3HOMEPAGE = "http://www.ode.org"
4LICENSE = "LGPLv2.1 & BSD"
5LIC_FILES_CHKSUM = "file://LICENSE-BSD.TXT;md5=c74e6304a772117e059458fb9763a928 \
6 file://LICENSE.TXT;md5=771782cb6245c7fbbe74bc0ec059beff"
7
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-src-${PV}.zip \
10 file://install.patch"
11
12SRC_URI[md5sum] = "4c03759b76a0649a6d5108c8e172e1e4"
13SRC_URI[sha256sum] = "460d0851b743b1f144ef2a8259004d6774504c95d08e9357a96a296111496feb"
14
15inherit autotools binconfig
16
17EXTRA_OECONF = "--disable-demos --enable-soname"
18
19do_configure_append() {
20 echo "#define dInfinity DBL_MAX" >>include/ode/config.h
21}
22
23FILES_${PN} = "${libdir}/lib*${SOLIBS}"
24
25PACKAGECONFIG ?= ""
26# if it isn't explicitly selected and "$build_os" == "$target_os", then configure will run
27# series of AC_TRY_RUN which won't work for cross-compilation and configure fails
28PACKAGECONFIG[double-precision] = "--enable-double-precision,--disable-double-precision"