summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/numactl/numactl_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-17 20:10:05 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:50 +0200
commitb9d8854ec0450a19b2dd6f54fb9f01201fd004d9 (patch)
tree1df06f9fbaa9dbb9923fe4f5f7483692a55289ac /meta-oe/recipes-support/numactl/numactl_git.bb
parentd45db2d6ec8ed5b4dbdd9c3de480ad7ac8ec0d83 (diff)
downloadmeta-openembedded-b9d8854ec0450a19b2dd6f54fb9f01201fd004d9.tar.gz
numactl: Update to latest from github
There are patches to compile it on musl upstream therefore switch the SRC_URI to fetch from github Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/numactl/numactl_git.bb')
-rw-r--r--meta-oe/recipes-support/numactl/numactl_git.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl_git.bb b/meta-oe/recipes-support/numactl/numactl_git.bb
new file mode 100644
index 000000000..f2d9a1760
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl_git.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Development package for building Applications that use numa"
2DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
3to run other programs with a specific NUMA policy and a libnuma to do \
4allocations with NUMA policy in applications."
5LICENSE = "GPL-2.0 & LGPL-2.1"
6SECTION = "apps"
7RDEPENDS_${PN} = "perl"
8
9inherit autotools-brokensep ptest
10
11LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
12
13SRCREV = "ea3a70681c2f523fe58e1d44527f478ca76db74e"
14PV = "2.0.11+git${SRCPV}"
15
16SRC_URI = "git://github.com/numactl/numactl \
17 file://fix-null-pointer.patch \
18 file://Fix-the-test-output-format.patch \
19 file://Makefile \
20 file://run-ptest \
21 file://0001-define-run-test-target.patch \
22"
23
24S = "${WORKDIR}/git"
25
26# ARM does not currently support NUMA
27COMPATIBLE_HOST = "^((?!arm).*)$"
28
29do_install() {
30 oe_runmake DESTDIR=${D} prefix=${D}/usr install
31 #remove the empty man2 directory
32 rm -r ${D}${mandir}/man2
33}
34
35do_compile_ptest() {
36 oe_runmake test
37}
38
39do_install_ptest() {
40 #install tests binaries
41 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
42 mynode nodemap node-parse pagesize prefered randmap realloc_test \
43 tbitmap tshared"
44
45 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
46 for i in $test_binaries; do
47 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
48 done
49
50 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
51 shmtest runltp bind_range"
52 for i in $test_scripts; do
53 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
54 done
55
56 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
57 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
58}
59
60RDEPENDS_${PN}-ptest = "bash"