summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc')
-rw-r--r--meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc94
1 files changed, 47 insertions, 47 deletions
diff --git a/meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc
index bac1be169..84846587b 100644
--- a/meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/nonworking/syslog-ng/syslog-ng.inc
@@ -16,41 +16,41 @@ SRC_URI = "http://www.balabit.com/downloads/files/syslog-ng/sources/${PV}/source
16noipv6 = "${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}" 16noipv6 = "${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}"
17 17
18EXTRA_OECONF = " \ 18EXTRA_OECONF = " \
19 --with-libnet=${STAGING_BINDIR_CROSS} \ 19 --with-libnet=${STAGING_BINDIR_CROSS} \
20 --enable-dynamic-linking \ 20 --enable-dynamic-linking \
21 ${noipv6} \ 21 ${noipv6} \
22 --enable-ssl \ 22 --enable-ssl \
23 --disable-sub-streams \ 23 --disable-sub-streams \
24 --disable-pacct \ 24 --disable-pacct \
25 --disable-linux-caps \ 25 --disable-linux-caps \
26 --disable-pcre \ 26 --disable-pcre \
27 --disable-sql \ 27 --disable-sql \
28" 28"
29 29
30EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" 30EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
31EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--enable-systemd', '--disable-systemd', d)}" 31EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--enable-systemd', '--disable-systemd', d)}"
32 32
33do_configure_prepend() { 33do_configure_prepend() {
34 eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}" 34 eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}"
35} 35}
36 36
37# rename modules.conf because it breaks update-modules 37# rename modules.conf because it breaks update-modules
38# see http://lists.linuxtogo.org/pipermail/openembedded-devel/2011-October/035537.html 38# see http://lists.linuxtogo.org/pipermail/openembedded-devel/2011-October/035537.html
39do_install_append() { 39do_install_append() {
40 mv ${D}/${sysconfdir}/modules.conf ${D}/${sysconfdir}/scl-modules.conf 40 mv ${D}/${sysconfdir}/modules.conf ${D}/${sysconfdir}/scl-modules.conf
41 sed -i "s#@include 'modules.conf'#@include 'scl-modules.conf'#g" ${D}/${sysconfdir}/scl.conf 41 sed -i "s#@include 'modules.conf'#@include 'scl-modules.conf'#g" ${D}/${sysconfdir}/scl.conf
42 install -d ${D}/${sysconfdir}/${PN} 42 install -d ${D}/${sysconfdir}/${PN}
43 install ${WORKDIR}/syslog-ng.conf ${D}${sysconfdir}/${PN}.conf 43 install ${WORKDIR}/syslog-ng.conf ${D}${sysconfdir}/${PN}.conf
44 install -d ${D}/${sysconfdir}/init.d 44 install -d ${D}/${sysconfdir}/init.d
45 install -m 755 ${WORKDIR}/initscript ${D}/${sysconfdir}/init.d/syslog.${PN} 45 install -m 755 ${WORKDIR}/initscript ${D}/${sysconfdir}/init.d/syslog.${PN}
46} 46}
47 47
48FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \ 48FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
49 ${sysconfdir} ${sharedstatedir} ${localstatedir} \ 49 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
50 ${base_bindir}/* ${base_sbindir}/* \ 50 ${base_bindir}/* ${base_sbindir}/* \
51 ${base_libdir}/*${SOLIBS} \ 51 ${base_libdir}/*${SOLIBS} \
52 ${datadir}/${BPN} ${libdir}/${BPN}/*${SOLIBS} \ 52 ${datadir}/${BPN} ${libdir}/${BPN}/*${SOLIBS} \
53 ${datadir}/include/scl/ ${datadir}/xsd" 53 ${datadir}/include/scl/ ${datadir}/xsd"
54FILES_${PN}-dev += "${libdir}/${BPN}/lib*.la ${libdir}/${BPN}/*${SOLIBSDEV}" 54FILES_${PN}-dev += "${libdir}/${BPN}/lib*.la ${libdir}/${BPN}/*${SOLIBSDEV}"
55CONFFILES_${PN} = "${sysconfdir}/${PN}.conf ${sysconfdir}/scl.conf ${sysconfdir}/scl-modules.conf" 55CONFFILES_${PN} = "${sysconfdir}/${PN}.conf ${sysconfdir}/scl.conf ${sysconfdir}/scl-modules.conf"
56 56
@@ -60,39 +60,39 @@ RCONFLICTS_${PN} += "${PN}-systemd"
60SYSTEMD_SERVICE_${PN} = "${PN}.service" 60SYSTEMD_SERVICE_${PN} = "${PN}.service"
61 61
62pkg_postinst_${PN} () { 62pkg_postinst_${PN} () {
63 /etc/init.d/syslog stop 63 /etc/init.d/syslog stop
64 update-alternatives --install ${sysconfdir}/init.d/syslog syslog-init syslog.${PN} 200 64 update-alternatives --install ${sysconfdir}/init.d/syslog syslog-init syslog.${PN} 200
65 65
66 if test "x$D" != "x"; then 66 if test "x$D" != "x"; then
67 OPT="-r $D" 67 OPT="-r $D"
68 else 68 else
69 OPT="-s" 69 OPT="-s"
70 fi 70 fi
71 # remove all rc.d-links potentially created from alternative 71 # remove all rc.d-links potentially created from alternative
72 # syslog packages before creating new ones 72 # syslog packages before creating new ones
73 update-rc.d $OPT -f syslog remove 73 update-rc.d $OPT -f syslog remove
74 update-rc.d $OPT syslog start 20 2 3 4 5 . stop 90 0 1 6 . 74 update-rc.d $OPT syslog start 20 2 3 4 5 . stop 90 0 1 6 .
75} 75}
76 76
77pkg_prerm_${PN} () { 77pkg_prerm_${PN} () {
78 if test "x$D" = "x"; then 78 if test "x$D" = "x"; then
79 if test "$1" = "upgrade" -o "$1" = "remove"; then 79 if test "$1" = "upgrade" -o "$1" = "remove"; then
80 /etc/init.d/syslog stop 80 /etc/init.d/syslog stop
81 fi
82 fi 81 fi
82 fi
83 83
84 update-alternatives --remove syslog-init syslog.${PN} 84 update-alternatives --remove syslog-init syslog.${PN}
85} 85}
86 86
87pkg_postrm_${PN} () { 87pkg_postrm_${PN} () {
88 if test "x$D" != "x"; then 88 if test "x$D" != "x"; then
89 OPT="-r $D" 89 OPT="-r $D"
90 else 90 else
91 OPT="" 91 OPT=""
92 fi 92 fi
93 if test "$1" = "remove" -o "$1" = "purge"; then 93 if test "$1" = "remove" -o "$1" = "purge"; then
94 if ! test -e "/etc/init.d/syslog"; then 94 if ! test -e "/etc/init.d/syslog"; then
95 update-rc.d $OPT syslog remove 95 update-rc.d $OPT syslog remove
96 fi
97 fi 96 fi
97 fi
98} 98}