summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-16 18:07:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-16 18:16:29 +0200
commit7f6b98b32b8b3a41607bac0586b862c064f94a9b (patch)
tree26987afaac144c0329e1c0d6883d3a81e77a36bd /meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
parenta45830a39bb47a9eab27980d52966226c9504ea4 (diff)
downloadmeta-openembedded-7f6b98b32b8b3a41607bac0586b862c064f94a9b.tar.gz
multipath-tools: move to right place
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
new file mode 100644
index 000000000..b52b11109
--- /dev/null
+++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "The upstream project used to drive the Device Mapper multipathing driver."
2
3DEPENDS = "lvm2 libaio readline"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
7
8
9SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http"
10SRCREV = "15fc23ffb2bd1bac6990eda3e23c3e8980e6cfa5"
11
12S = "${WORKDIR}/git"
13
14PV = "0.4.9+git"
15
16EXTRA_OEMAKE = "MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} libdir=${base_libdir}/multipath"
17
18do_install() {
19 oe_runmake install
20}
21
22FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
23FILES_${PN} += "${base_libdir}/multipath \
24 ${base_libdir}/systemd"
25
26PACKAGES =+ "kpartx"
27FILES_kpartx = "${base_sbindir}/kpartx \
28 ${base_libdir}/udev/kpartx_id"
29
30RDEPENDS_${PN} += "kpartx"