summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2014-09-22 17:22:32 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:54 +0200
commit48e5c5ef39d70c3b00f755d09811f497e6d23f53 (patch)
tree595d81d3ee1e3bc91f1949c5a05f060fa9216712 /meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
parent0a67b9f3fd164b808c66286ff0435c65421e5352 (diff)
downloadmeta-openembedded-48e5c5ef39d70c3b00f755d09811f497e6d23f53.tar.gz
multipath-tools: update to version 0.5.0+
SCRREV includes patches up to 9/12/2014. Modify upstream source to be better set up for cross compilation. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb58
1 files changed, 49 insertions, 9 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
index 038f4e26d..055cfe64c 100644
--- a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
+++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
@@ -1,30 +1,70 @@
1SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver" 1SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
2 2
3DEPENDS = "lvm2 libaio readline" 3DEPENDS = "lvm2 libaio readline udev"
4 4
5LICENSE = "GPLv2" 5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
7 6
7SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
8 file://multipathd.oe \
9 file://makefile_inc.patch \
10 file://always-use-libdevmapper.patch \
11 file://always-use-libdevmapper-kpartx.patch \
12 "
13# 0.5.0
14#
15#SRCREV = "82f391e787dc02e9d9294aa391137ab424bb83c4"
16#LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
17
18# 0.5.0 + commits thru 7/18/2014
19#
20#SRCREV = "0d72f46c12207a6b7b89f5ef4f5ab5f87ed8bc90"
21#LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
22
23# 0.5.0 + commits thru 9/12/2014
24#
25# includes important systemd related structure size fix
26#
27SRCREV = "aec68ab217fd2956443b27ceeb97dd6475267789"
28LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
29
30inherit systemd
8 31
9SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http"
10SRCREV = "15fc23ffb2bd1bac6990eda3e23c3e8980e6cfa5"
11 32
12S = "${WORKDIR}/git" 33S = "${WORKDIR}/git"
13 34
14PV = "0.4.9+git" 35PV = "0.5.0+git${@'${SRCPV}'.split('+')[-1]}"
15 36
16EXTRA_OEMAKE = "MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} libdir=${base_libdir}/multipath" 37# The exact version of SYSTEMD does not matter but should be greater than 209.
38#
39EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
40 OPTFLAGS="${CFLAGS}" \
41 LIB=${base_libdir} libdir=${base_libdir}/multipath \
42 unitdir=/lib/systemd/system \
43 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
44 '
17 45
18do_install() { 46do_install() {
19 oe_runmake install 47 oe_runmake install
48
49 # Copy a sample conf file, but do not rename it multipath.conf.
50 #
51 cp multipath.conf.defaults ${D}${sysconfdir}
52
53 # We copy an initscript, but do not start multipathd at init time.
54 #
55 cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
56
20} 57}
21 58
22FILES_${PN}-dbg += "${base_libdir}/multipath/.debug" 59FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
60
61# systemd and udev stuff always goes under /lib!
62#
23FILES_${PN} += "${base_libdir}/multipath \ 63FILES_${PN} += "${base_libdir}/multipath \
24 ${base_libdir}/systemd" 64 /lib/systemd"
25 65
26PACKAGES =+ "kpartx" 66PACKAGES =+ "kpartx"
27FILES_kpartx = "${base_sbindir}/kpartx \ 67FILES_kpartx = "${base_sbindir}/kpartx \
28 ${base_libdir}/udev/kpartx_id" 68 /lib/udev/kpartx_id"
29 69
30RDEPENDS_${PN} += "kpartx" 70RDEPENDS_${PN} += "kpartx"