summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-07-05 05:13:17 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:30 +0200
commit1acfde8120eaa290df64f709e5a322bd6a44d19c (patch)
tree13d387707da99934f98ba276efe497f0d8c40388 /meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
parent5688c8e24cf106f8248ea44e98ba15931844ed9b (diff)
downloadmeta-openembedded-1acfde8120eaa290df64f709e5a322bd6a44d19c.tar.gz
multipath-tools: 0.6.4 -> 0.7.1
1. In fedora/redhat, it is renamed to device-mapper-multipath, use PROVIDE and RPROVIDE to support. 2. Split ${PN}-libs 3. Add multipath.conf.example 4. Backport patches from fedora: git://pkgs.fedoraproject.org/rpms/device-mapper-multipath - 0001 ~ 0011 5. Rebase local patches: - makefile_inc.patch -> 0012-multipath-tools-modify-Makefile.inc-for-cross-compil.patch - always-use-libdevmapper.patch -> 0013-Always-use-devmapper.patch - always-use-libdevmapper-kpartx.patch -> 0014-Always-use-devmapper-for-kpartx.patch 6. Drop obsolete patches: - 0001-multipathd.service-Error-fix.patch - shared-libs-avoid-linking-.so-as-executable.patch - checkers-disable-libcheckrbd.so.patch Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
deleted file mode 100644
index 5f8c42257..000000000
--- a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
2
3DEPENDS = "libdevmapper libaio liburcu readline udev"
4
5LICENSE = "LGPLv2"
6
7SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
8 file://multipathd.oe \
9 file://makefile_inc.patch \
10 file://always-use-libdevmapper.patch \
11 file://always-use-libdevmapper-kpartx.patch \
12 file://0001-multipathd.service-Error-fix.patch \
13 file://shared-libs-avoid-linking-.so-as-executable.patch \
14 file://checkers-disable-libcheckrbd.so.patch \
15 "
16LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
17
18# 0.6.4
19SRCREV = "922421cf795d53d339862bb2d99f1a85c96ad9a3"
20
21inherit systemd
22
23
24S = "${WORKDIR}/git"
25
26PV = "0.6.4+git${@'${SRCPV}'.split('+')[-1]}"
27
28TARGET_CC_ARCH += "${LDFLAGS}"
29
30# multipath-tools includes a copy of the valgrind.h header
31# file and uses the macros to suppress some false positives. However,
32# that only works on ARM when thumb is disabled. Otherwise one gets:
33# Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
34# ../Makefile.inc:66: recipe for target 'debug.o' failed
35ARM_INSTRUCTION_SET_armv4 = "arm"
36ARM_INSTRUCTION_SET_armv5 = "arm"
37
38# The exact version of SYSTEMD does not matter but should be greater than 209.
39#
40EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
41 OPTFLAGS="${CFLAGS}" \
42 bindir=${base_sbindir} \
43 LIB=${base_libdir} libdir=${base_libdir}/multipath \
44 unitdir=${systemd_system_unitdir} \
45 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
46 '
47
48do_install() {
49 oe_runmake install
50
51 # We copy an initscript, but do not start multipathd at init time.
52 #
53 install -d ${D}${sysconfdir}/init.d
54 cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
55
56}
57
58FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
59
60# systemd and udev stuff always goes under /lib!
61#
62FILES_${PN} += "${base_libdir}/multipath \
63 ${systemd_system_unitdir} \
64 "
65
66PACKAGES =+ "kpartx"
67FILES_kpartx = "${base_sbindir}/kpartx \
68 ${nonarch_libdir}/udev/kpartx_id \
69 "
70
71RDEPENDS_${PN} += "kpartx"