summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mailcap/mailcap_2.1.54.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-05-25 14:56:15 +0800
committerKhem Raj <raj.khem@gmail.com>2023-05-25 08:57:47 -0700
commit615f1c30783400ffa7b5bf551a3a8c0ce4503c16 (patch)
treebe4a4e8efff25e5f977b0758e6a1d15c6bdbdc48 /meta-oe/recipes-support/mailcap/mailcap_2.1.54.bb
parentaf46875f2acece2d7e691777bb1a2382900bbc5d (diff)
downloadmeta-openembedded-615f1c30783400ffa7b5bf551a3a8c0ce4503c16.tar.gz
mailcap: upgrade 2.1.53 -> 2.1.54
Changelog: ========== - mime.types: Sync with IANA as of 2023-05-22 - typediff.py: remove unnecessary import Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mailcap/mailcap_2.1.54.bb')
-rw-r--r--meta-oe/recipes-support/mailcap/mailcap_2.1.54.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mailcap/mailcap_2.1.54.bb b/meta-oe/recipes-support/mailcap/mailcap_2.1.54.bb
new file mode 100644
index 000000000..8385b6354
--- /dev/null
+++ b/meta-oe/recipes-support/mailcap/mailcap_2.1.54.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Helper application and MIME type associations for file types"
2HOMEPAGE = "https://pagure.io/mailcap"
3DESCRIPTION = "The mailcap file is used by the metamail program. Metamail reads the \
4mailcap file to determine how it should display non-text or multimedia \
5material. Basically, mailcap associates a particular type of file \
6with a particular program that a mail agent or other program can call \
7in order to handle the file. Mailcap should be installed to allow \
8certain programs to be able to handle non-text files. \
9\
10Also included in this package is the mime.types file which contains a \
11list of MIME types and their filename extension associations, used \
12by several applications e.g. to determine MIME types for filenames."
13
14SECTION = "System Environment/Base"
15
16LICENSE = "PD & MIT"
17LIC_FILES_CHKSUM = "file://COPYING;md5=8dce08227d135cfda1f19d4c0c6689de"
18
19SRC_URI = "https://releases.pagure.org/${BPN}/${BP}.tar.xz"
20
21SRC_URI[sha256sum] = "9a4032202fc0d2b0858f41b167389a9cfe52ac24ec282e6479b90765319de113"
22
23inherit update-alternatives
24
25do_install() {
26 oe_runmake install DESTDIR=${D} sysconfdir=${sysconfdir} mandir=${mandir}
27}
28
29ALTERNATIVE:${PN} = "mime.types"
30ALTERNATIVE_LINK_NAME[mime.types] = "${sysconfdir}/mime.types"