summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lvm2
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-08-22 17:48:30 +0800
committerKhem Raj <raj.khem@gmail.com>2019-08-24 04:31:45 -0700
commitfbe17b57d8a9ee2aa623955470b11a67e6adcffd (patch)
treebe5823251da4a91a00706a149fc710140189bdfa /meta-oe/recipes-support/lvm2
parent2c0031a81c9c3f27cabea5ca8c22a8fdfbba64c2 (diff)
downloadmeta-openembedded-fbe17b57d8a9ee2aa623955470b11a67e6adcffd.tar.gz
lvm2: fix circular dependencies while systemd enable cryptsetup
While systemd enable cryptsetup (PACKAGECONFIG_append_pn-systemd = ' cryptsetup'), there is a circular dependencies: systemd -> systemd -> cryptsetup -> libdevmapper -> udev (PREFERRED_PROVIDER_udev = systemd) The libdevmapper was used to break circular dependencies, it does not require udev, refer commit [698d512 lvm2: Add a PACKAGECONFIG for udev support] to move udev related from lvm2.inc to lvm2.bb Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lvm2')
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2.inc4
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2_2.03.02.bb6
2 files changed, 7 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-oe/recipes-support/lvm2/lvm2.inc
index ca409a6f1..f358663b0 100644
--- a/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -5,7 +5,7 @@ LICENSE = "GPLv2 & LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=12713b4d9386533feeb07d6e4831765a \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=12713b4d9386533feeb07d6e4831765a \
6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24" 6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24"
7 7
8DEPENDS += "util-linux libaio" 8DEPENDS += "libaio"
9 9
10SRC_URI = "https://sourceware.org/pub/lvm2/LVM2.${PV}.tgz \ 10SRC_URI = "https://sourceware.org/pub/lvm2/LVM2.${PV}.tgz \
11 file://lvm.conf \ 11 file://lvm.conf \
@@ -27,7 +27,6 @@ LVM2_PACKAGECONFIG = "dmeventd"
27LVM2_PACKAGECONFIG_append_class-target = " \ 27LVM2_PACKAGECONFIG_append_class-target = " \
28 ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)} \ 28 ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)} \
29 ${@incompatible_license_contains('GPLv3', '', 'thin-provisioning-tools', d)} \ 29 ${@incompatible_license_contains('GPLv3', '', 'thin-provisioning-tools', d)} \
30 udev \
31" 30"
32 31
33# odirect is always enabled because there currently is a bug in 32# odirect is always enabled because there currently is a bug in
@@ -41,7 +40,6 @@ PACKAGECONFIG[odirect] = "--enable-o_direct,--disable-o_direct"
41PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline" 40PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
42PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux" 41PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
43PACKAGECONFIG[thin-provisioning-tools] = "--with-thin=internal,--with-thin=none,,thin-provisioning-tools" 42PACKAGECONFIG[thin-provisioning-tools] = "--with-thin=internal,--with-thin=none,,thin-provisioning-tools"
44PACKAGECONFIG[udev] = "--enable-udev_sync --enable-udev_rules --with-udevdir=${nonarch_base_libdir}/udev/rules.d,--disable-udev_sync --disable-udev_rules,udev"
45 43
46# Unset user/group to unbreak install. 44# Unset user/group to unbreak install.
47EXTRA_OECONF = "--with-user= \ 45EXTRA_OECONF = "--with-user= \
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.03.02.bb b/meta-oe/recipes-support/lvm2/lvm2_2.03.02.bb
index 4ae0a62ab..9922ef79d 100644
--- a/meta-oe/recipes-support/lvm2/lvm2_2.03.02.bb
+++ b/meta-oe/recipes-support/lvm2/lvm2_2.03.02.bb
@@ -40,6 +40,12 @@ TARGET_CC_ARCH += "${LDFLAGS}"
40 40
41EXTRA_OECONF_append_class-nativesdk = " --with-confdir=${sysconfdir}" 41EXTRA_OECONF_append_class-nativesdk = " --with-confdir=${sysconfdir}"
42 42
43DEPENDS += "util-linux"
44LVM2_PACKAGECONFIG_append_class-target = " \
45 udev \
46"
47PACKAGECONFIG[udev] = "--enable-udev_sync --enable-udev_rules --with-udevdir=${nonarch_base_libdir}/udev/rules.d,--disable-udev_sync --disable-udev_rules,udev"
48
43FILES_${PN} += "${libdir}/device-mapper/*.so" 49FILES_${PN} += "${libdir}/device-mapper/*.so"
44FILES_${PN}-scripts = " \ 50FILES_${PN}-scripts = " \
45 ${sbindir}/blkdeactivate \ 51 ${sbindir}/blkdeactivate \