summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libusbgx/libusbgx-config.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-11-30 20:43:36 -0200
committerKhem Raj <raj.khem@gmail.com>2018-11-30 17:12:36 -0800
commitf29268ee21106dfd9f578088745c43aa5e6ed3a3 (patch)
tree853ad416cd3f3056b59e94f55a0b361879d92e52 /meta-oe/recipes-support/libusbgx/libusbgx-config.bb
parentebc7b9e20ac22f6f2ad373621917f53e8a9af81c (diff)
downloadmeta-openembedded-f29268ee21106dfd9f578088745c43aa5e6ed3a3.tar.gz
libusbgx: Add recipe
The libusbgx allow easier use and setup of USB gadgets. To easy integration on different systems a libusbgx-config package is provided so it can be used to start and enable respective USB gadget schema. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libusbgx/libusbgx-config.bb')
-rw-r--r--meta-oe/recipes-support/libusbgx/libusbgx-config.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libusbgx/libusbgx-config.bb b/meta-oe/recipes-support/libusbgx/libusbgx-config.bb
new file mode 100644
index 000000000..b269e33c4
--- /dev/null
+++ b/meta-oe/recipes-support/libusbgx/libusbgx-config.bb
@@ -0,0 +1,12 @@
1SUMMARY = "USB Gadget Configuration Files"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5SRC_URI = "file://usbgx.default"
6
7do_configure[noexec] = "1"
8do_compile[noexec] = "1"
9
10do_install() {
11 install -Dm 0644 ${WORKDIR}/usbgx.default ${D}${sysconfdir}/default/usbgx
12}