summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libusbg
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-08-04 09:07:34 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-10 16:07:17 +0200
commit6576cddf6b66c34e9ea550d8dd0819c559237b5a (patch)
tree61fb10fe9fa2ea601ade2d9529023ece0629a497 /meta-oe/recipes-support/libusbg
parent2d2e49e79318889268f6e3293c2127c13be5cd6b (diff)
downloadmeta-openembedded-6576cddf6b66c34e9ea550d8dd0819c559237b5a.tar.gz
libusbg: update to latest git and fix S!=B
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libusbg')
-rw-r--r--meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch39
-rw-r--r--meta-oe/recipes-support/libusbg/libusbg_git.bb8
2 files changed, 43 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch b/meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch
new file mode 100644
index 000000000..6be49fbca
--- /dev/null
+++ b/meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch
@@ -0,0 +1,39 @@
1From 6118c6ec1291a5c731aa8d4f0c1eb8cce43d47ad Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Mon, 4 Aug 2014 09:04:08 +0200
4Subject: [PATCH] Fix out-of-tree builds
5
6The include flag should point to the source directory, not the build
7directory.
8
9Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
10Upstream-status: Submitted [https://github.com/libusbg/libusbg/pull/9]
11---
12 examples/Makefile.am | 2 +-
13 src/Makefile.am | 2 +-
14 2 files changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/examples/Makefile.am b/examples/Makefile.am
17index f9f9407..ef4f81e 100644
18--- a/examples/Makefile.am
19+++ b/examples/Makefile.am
20@@ -1,5 +1,5 @@
21 bin_PROGRAMS = show-gadgets gadget-acm-ecm
22 gadget_acm_ecm_SOURCES = gadget-acm-ecm.c
23 show_gadgets_SOURCES = show-gadgets.c
24-AM_CPPFLAGS=-I../include/
25+AM_CPPFLAGS=-I$(top_srcdir)/include/
26 AM_LDFLAGS=-L../src/ -lusbg
27diff --git a/src/Makefile.am b/src/Makefile.am
28index d955a4c..2f71366 100644
29--- a/src/Makefile.am
30+++ b/src/Makefile.am
31@@ -1,4 +1,4 @@
32 lib_LTLIBRARIES = libusbg.la
33 libusbg_la_SOURCES = usbg.c
34 libusbg_la_LDFLAGS = -version-info 0:1:0
35-AM_CPPFLAGS=-I../include/
36+AM_CPPFLAGS=-I$(top_srcdir)/include/
37--
381.9.0
39
diff --git a/meta-oe/recipes-support/libusbg/libusbg_git.bb b/meta-oe/recipes-support/libusbg/libusbg_git.bb
index 280983b1f..97d60a6a8 100644
--- a/meta-oe/recipes-support/libusbg/libusbg_git.bb
+++ b/meta-oe/recipes-support/libusbg/libusbg_git.bb
@@ -6,11 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 6
7inherit autotools 7inherit autotools
8 8
9PNBLACKLIST[libusbg] = "BROKEN: Doesn't work with B!=S and nobody sent patch to fix it"
10
11PV = "0.1.0" 9PV = "0.1.0"
12SRCREV = "7e2b04363f319e8936a606bdb122dbde249a2f58" 10SRCREV = "a826d136e0e8fa53815f1ba05893e6dd74208c15"
13SRC_URI = "git://github.com/libusbg/libusbg.git" 11SRC_URI = "git://github.com/libusbg/libusbg.git \
12 file://0001-Fix-out-of-tree-builds.patch \
13 "
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16