diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-02-17 19:23:43 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-17 19:24:59 -0800 |
commit | d982e00d59c73bf118c5c03b7cae0cb9d681b411 (patch) | |
tree | 5afce8db58b46eae482e0e437271b6edb162cf06 /meta-oe/recipes-support/liburing | |
parent | 7b7a8412a41ba96cc19ee330c764753fdb04ceb8 (diff) | |
download | meta-openembedded-d982e00d59c73bf118c5c03b7cae0cb9d681b411.tar.gz |
liburing: Do not build examples on risc/musl
it needs ucontext for building examples and its not implemented yet for
riscv
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/liburing')
-rw-r--r-- | meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-support/liburing/liburing_0.7.bb | 7 |
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch b/meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch new file mode 100644 index 0000000000..19bf14708b --- /dev/null +++ b/meta-oe/recipes-support/liburing/liburing/0001-do-not-build-examples.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 3ee2f1e231bde18a99f86da747a9b8feca3c179d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 17 Feb 2021 19:18:16 -0800 | ||
4 | Subject: [PATCH] do not build examples | ||
5 | |||
6 | examples need ucontext and some architectures on musl do not have it | ||
7 | implemented e.g. riscv | ||
8 | |||
9 | Upstream-Status: Inappropriate [Arch-Specific] | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | Makefile | 1 - | ||
14 | 1 file changed, 1 deletion(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index 948e004..8b63024 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -11,7 +11,6 @@ default: all | ||
21 | all: | ||
22 | @$(MAKE) -C src | ||
23 | @$(MAKE) -C test | ||
24 | - @$(MAKE) -C examples | ||
25 | |||
26 | partcheck: all | ||
27 | @echo "make partcheck => TODO add tests with out kernel support" | ||
28 | -- | ||
29 | 2.30.1 | ||
30 | |||
diff --git a/meta-oe/recipes-support/liburing/liburing_0.7.bb b/meta-oe/recipes-support/liburing/liburing_0.7.bb index e122a907cd..d79389a696 100644 --- a/meta-oe/recipes-support/liburing/liburing_0.7.bb +++ b/meta-oe/recipes-support/liburing/liburing_0.7.bb | |||
@@ -12,6 +12,9 @@ LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e | |||
12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \ | 12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \ |
13 | file://0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch \ | 13 | file://0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch \ |
14 | " | 14 | " |
15 | SRC_URI_append_libc-musl_riscv64 = " file://0001-do-not-build-examples.patch " | ||
16 | SRC_URI_append_libc-musl_riscv32 = " file://0001-do-not-build-examples.patch " | ||
17 | |||
15 | SRCREV = "45f0735219a615ae848033c47c7e2d85d101d43e" | 18 | SRCREV = "45f0735219a615ae848033c47c7e2d85d101d43e" |
16 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
17 | 20 | ||
@@ -20,7 +23,9 @@ XCFLAGS = "-pthread" | |||
20 | XCFLAGS_append_libc-musl = " -lucontext" | 23 | XCFLAGS_append_libc-musl = " -lucontext" |
21 | 24 | ||
22 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'" | 25 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'" |
23 | 26 | do_configure() { | |
27 | ${S}/configure --prefix=${prefix} | ||
28 | } | ||
24 | do_install () { | 29 | do_install () { |
25 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir} | 30 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir} |
26 | } | 31 | } |