diff options
author | Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> | 2021-10-29 12:25:03 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-01 05:45:17 -0700 |
commit | 2dd1a2f2a9730326a4b1b32f6246ae93178906eb (patch) | |
tree | 5ce34e2781aa9755957b68b2740823b1a4f4ca49 /meta-oe/recipes-support/liburing | |
parent | b66ad223244977acd2ec38ab38b7ed896fb80429 (diff) | |
download | meta-openembedded-2dd1a2f2a9730326a4b1b32f6246ae93178906eb.tar.gz |
liburing: update to 2.1
Removed upstreamed patcches.
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/liburing')
-rw-r--r-- | meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch | 37 | ||||
-rw-r--r-- | meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch | 53 | ||||
-rw-r--r-- | meta-oe/recipes-support/liburing/liburing_2.1.bb (renamed from meta-oe/recipes-support/liburing/liburing_2.0.bb) | 7 |
3 files changed, 2 insertions, 95 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch b/meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch deleted file mode 100644 index a2ba66c3ab..0000000000 --- a/meta-oe/recipes-support/liburing/liburing/0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From a30d62dfb9ea30af58ef331fae1e6f727d0558c0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 4 May 2021 10:32:08 -0700 | ||
4 | Subject: [PATCH] examples/ucontext-cp.c: Do not use SIGSTKSZ | ||
5 | |||
6 | glibc 2.34 has removed SIGSTKSZ therefore we replace it | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | examples/ucontext-cp.c | 6 +----- | ||
11 | 1 file changed, 1 insertion(+), 5 deletions(-) | ||
12 | |||
13 | --- a/examples/ucontext-cp.c | ||
14 | +++ b/examples/ucontext-cp.c | ||
15 | @@ -3,6 +3,7 @@ | ||
16 | * gcc -Wall -O2 -D_GNU_SOURCE -o ucontext-cp ucontext-cp.c -luring | ||
17 | */ | ||
18 | #define _POSIX_C_SOURCE 199309L | ||
19 | +#include <stddef.h> | ||
20 | #include <stdio.h> | ||
21 | #include <fcntl.h> | ||
22 | #include <string.h> | ||
23 | @@ -22,13 +23,9 @@ | ||
24 | #define QD 64 | ||
25 | #define BS 1024 | ||
26 | |||
27 | -#ifndef SIGSTKSZ | ||
28 | -#define SIGSTKSZ 8192 | ||
29 | -#endif | ||
30 | - | ||
31 | typedef struct { | ||
32 | struct io_uring *ring; | ||
33 | - unsigned char stack_buf[SIGSTKSZ]; | ||
34 | + max_align_t stack_buf[(8 * 1024 + sizeof (max_align_t) - 1) / sizeof (max_align_t)]; | ||
35 | ucontext_t ctx_main, ctx_fnew; | ||
36 | } async_context; | ||
37 | |||
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch b/meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch deleted file mode 100644 index f2f03c18b4..0000000000 --- a/meta-oe/recipes-support/liburing/liburing/0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | From 2d3940163e14d183fddc4d8b24cc1d3865bba0b3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 5 May 2021 09:36:36 -0700 | ||
4 | Subject: [PATCH] tests: fix portability issue when using __NR_mmap syscall | ||
5 | |||
6 | On some architectures e.g. ARM and RISCV32, __NR_mmap does not exist and | ||
7 | libc will then use NR_mmap2 to implement mmap() API, therefore use | ||
8 | system C library mmap() API instead of calling the syscall directly | ||
9 | |||
10 | Upstream-Status: Partial Backport [https://github.com/axboe/liburing/commit/808b6c72ab753bda0c300b5683cfd31750d1d49b] | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | test/double-poll-crash.c | 6 +++--- | ||
14 | test/sqpoll-disable-exit.c | 6 +++--- | ||
15 | 2 files changed, 6 insertions(+), 6 deletions(-) | ||
16 | |||
17 | diff --git a/test/double-poll-crash.c b/test/double-poll-crash.c | ||
18 | index 1a219c7..6e08285 100644 | ||
19 | --- a/test/double-poll-crash.c | ||
20 | +++ b/test/double-poll-crash.c | ||
21 | @@ -150,9 +150,9 @@ int main(int argc, char *argv[]) | ||
22 | if (argc > 1) | ||
23 | return 0; | ||
24 | |||
25 | - syscall(__NR_mmap, 0x1ffff000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul); | ||
26 | - syscall(__NR_mmap, 0x20000000ul, 0x1000000ul, 7ul, 0x32ul, -1, 0ul); | ||
27 | - syscall(__NR_mmap, 0x21000000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul); | ||
28 | + mmap((void *) 0x1ffff000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0); | ||
29 | + mmap((void *) 0x20000000, (size_t) 0x1000000, PROT_READ | PROT_WRITE | PROT_EXEC, MAP_FIXED | MAP_ANONYMOUS, -1, 0); | ||
30 | + mmap((void *) 0x21000000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0); | ||
31 | intptr_t res = 0; | ||
32 | *(uint32_t*)0x20000484 = 0; | ||
33 | *(uint32_t*)0x20000488 = 0; | ||
34 | diff --git a/test/sqpoll-disable-exit.c b/test/sqpoll-disable-exit.c | ||
35 | index d4e17f8..a0d00cc 100644 | ||
36 | --- a/test/sqpoll-disable-exit.c | ||
37 | +++ b/test/sqpoll-disable-exit.c | ||
38 | @@ -223,9 +223,9 @@ void execute_one(void) | ||
39 | } | ||
40 | int main(void) | ||
41 | { | ||
42 | - syscall(__NR_mmap, 0x1ffff000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul); | ||
43 | - syscall(__NR_mmap, 0x20000000ul, 0x1000000ul, 7ul, 0x32ul, -1, 0ul); | ||
44 | - syscall(__NR_mmap, 0x21000000ul, 0x1000ul, 0ul, 0x32ul, -1, 0ul); | ||
45 | + mmap((void *) 0x1ffff000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0); | ||
46 | + mmap((void *) 0x20000000, (size_t) 0x1000000, PROT_READ | PROT_WRITE | PROT_EXEC, MAP_FIXED | MAP_ANONYMOUS, -1, 0); | ||
47 | + mmap((void *) 0x21000000, (size_t) 0x1000, PROT_NONE, MAP_FIXED | MAP_ANONYMOUS, -1, 0); | ||
48 | loop(); | ||
49 | return 0; | ||
50 | } | ||
51 | -- | ||
52 | 2.31.1 | ||
53 | |||
diff --git a/meta-oe/recipes-support/liburing/liburing_2.0.bb b/meta-oe/recipes-support/liburing/liburing_2.1.bb index 7a903e5d4a..b4f0b11f4e 100644 --- a/meta-oe/recipes-support/liburing/liburing_2.0.bb +++ b/meta-oe/recipes-support/liburing/liburing_2.1.bb | |||
@@ -9,14 +9,11 @@ SECTION = "libs" | |||
9 | LICENSE = "LGPLv2.1 | MIT" | 9 | LICENSE = "LGPLv2.1 | MIT" |
10 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9" | 10 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9" |
11 | 11 | ||
12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \ | 12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https" |
13 | file://0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch \ | ||
14 | file://0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch \ | ||
15 | " | ||
16 | SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch " | 13 | SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch " |
17 | SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch " | 14 | SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch " |
15 | SRCREV = "41a61c97c2e3df4475c93fdf5026d575ce3f1377" | ||
18 | 16 | ||
19 | SRCREV = "b013dfd5a5f65116373d5e0f0bdfb73db9d8816e" | ||
20 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
21 | 18 | ||
22 | DEPENDS:append:libc-musl = " libucontext" | 19 | DEPENDS:append:libc-musl = " libucontext" |