summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/liburing
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-02-18 18:12:42 -0800
committerKhem Raj <raj.khem@gmail.com>2023-02-18 18:13:51 -0800
commit1877172e97d4a48ec9805a02b870ac4ccc57962b (patch)
tree87733359d23b876a21ac2e82eb2807ff9867a06b /meta-oe/recipes-support/liburing
parent967094eed959592582a6f2c94a7e472b34f3bb36 (diff)
downloadmeta-openembedded-1877172e97d4a48ec9805a02b870ac4ccc57962b.tar.gz
liburing: Update to latest tip of tree
Add a patch to fix build on musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/liburing')
-rw-r--r--meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch47
-rw-r--r--meta-oe/recipes-support/liburing/liburing_2.3.bb6
2 files changed, 51 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch b/meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch
new file mode 100644
index 000000000..21aaf8d99
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing/0001-examples-test-Remove-unused-linux-errqueue.h.patch
@@ -0,0 +1,47 @@
1From 0fbcc44fe1fb2dc6807660b2cff1c2995add095b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Feb 2023 18:01:22 -0800
4Subject: [PATCH] examples,test: Remove unused linux/errqueue.h
5
6This header is not needed therefore remove it, this cleanup also helps
7compiling on musl/clang
8
9/usr/include/linux/errqueue.h:57:20: error: array has incomplete element typ
10e 'struct timespec'
11 struct timespec ts[3];
12 ^
13
14Upstream-Status: Submitted [https://github.com/axboe/liburing/pull/798]
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 examples/send-zerocopy.c | 1 -
18 test/send-zerocopy.c | 1 -
19 2 files changed, 2 deletions(-)
20
21diff --git a/examples/send-zerocopy.c b/examples/send-zerocopy.c
22index 6092af9..cf1fa8b 100644
23--- a/examples/send-zerocopy.c
24+++ b/examples/send-zerocopy.c
25@@ -13,7 +13,6 @@
26 #include <string.h>
27
28 #include <arpa/inet.h>
29-#include <linux/errqueue.h>
30 #include <linux/if_packet.h>
31 #include <linux/ipv6.h>
32 #include <linux/socket.h>
33diff --git a/test/send-zerocopy.c b/test/send-zerocopy.c
34index 86a31cd..5d578c6 100644
35--- a/test/send-zerocopy.c
36+++ b/test/send-zerocopy.c
37@@ -11,7 +11,6 @@
38 #include <string.h>
39
40 #include <arpa/inet.h>
41-#include <linux/errqueue.h>
42 #include <linux/if_packet.h>
43 #include <linux/ipv6.h>
44 #include <linux/socket.h>
45--
462.39.2
47
diff --git a/meta-oe/recipes-support/liburing/liburing_2.3.bb b/meta-oe/recipes-support/liburing/liburing_2.3.bb
index b3da4d5e0..ba9b7480c 100644
--- a/meta-oe/recipes-support/liburing/liburing_2.3.bb
+++ b/meta-oe/recipes-support/liburing/liburing_2.3.bb
@@ -9,11 +9,13 @@ SECTION = "libs"
9LICENSE = "LGPL-2.1-only | MIT" 9LICENSE = "LGPL-2.1-only | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af" 10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
11 11
12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https" 12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
13 file://0001-examples-test-Remove-unused-linux-errqueue.h.patch"
13SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch " 14SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
14SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch " 15SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
15SRCREV = "4915f2af869876d892a1f591ee2c21be21c6fc5c" 16SRCREV = "f5cac78e621ab452d3035902085f66d2bf73243b"
16 17
18PV .= "+2.4+git${SRCPV}"
17S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
18 20
19DEPENDS:append:libc-musl = " libucontext" 21DEPENDS:append:libc-musl = " libucontext"