summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/liburing/liburing_2.5.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-23 18:46:14 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-23 19:02:36 -0700
commit4a40270d16d6597225061e58c108768dca19a767 (patch)
treef9a8c2e35d333e94b5a2ec52d74ebd0061b983fc /meta-oe/recipes-support/liburing/liburing_2.5.bb
parenta06056e78964369fa1ecdfdbc5a99895f232d083 (diff)
downloadmeta-openembedded-4a40270d16d6597225061e58c108768dca19a767.tar.gz
liburing: Upgrade to 2.5
Changelogs are here [1] [1] https://github.com/axboe/liburing/commit/f4e42a515cd78c8c9cac2be14222834be5f8df2b Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/liburing/liburing_2.5.bb')
-rw-r--r--meta-oe/recipes-support/liburing/liburing_2.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/liburing/liburing_2.5.bb b/meta-oe/recipes-support/liburing/liburing_2.5.bb
new file mode 100644
index 000000000..440259ffb
--- /dev/null
+++ b/meta-oe/recipes-support/liburing/liburing_2.5.bb
@@ -0,0 +1,29 @@
1SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
9LICENSE = "LGPL-2.1-only | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
11
12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https"
13SRCREV = "f4e42a515cd78c8c9cac2be14222834be5f8df2b"
14
15S = "${WORKDIR}/git"
16
17DEPENDS:append:libc-musl = " libucontext"
18XCFLAGS = "-pthread"
19XCFLAGS:append:libc-musl = " -lucontext"
20
21EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
22do_configure() {
23 ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir}
24}
25do_install () {
26 oe_runmake install DESTDIR=${D}
27}
28
29BBCLASSEXTEND = "native nativesdk"