summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2018-05-24 14:26:50 -0400
committerKhem Raj <raj.khem@gmail.com>2018-05-29 12:56:19 -0700
commita5e0b35c70f62ee14cc53e9b6edfb1bb448400a0 (patch)
tree514da49f8156e8c6ef16a60b4406dbb095c611ce /meta-oe/recipes-support/libssh
parent2d07e06ce9cf2c6b9dfb339e396514bf7a351bdd (diff)
downloadmeta-openembedded-a5e0b35c70f62ee14cc53e9b6edfb1bb448400a0.tar.gz
libssh: variable cleanup
Reorder recipe variables according to: https://www.openembedded.org/wiki/Styleguide Originally-conceived-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.7.3.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.7.3.bb b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
index e5ea2b8bf..6064969ae 100644
--- a/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
+++ b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
@@ -1,16 +1,21 @@
1SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol" 1SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org" 2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs" 3SECTION = "libs"
4
5DEPENDS = "zlib openssl libgcrypt"
6
7LICENSE = "LGPLv2.1" 4LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139" 5LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
9 6
7DEPENDS = "zlib openssl libgcrypt"
8
10SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7" 9SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
11SRCREV = "cdf7690e038230623cbbf6b024ece62f41efa98d" 10SRCREV = "cdf7690e038230623cbbf6b024ece62f41efa98d"
11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14inherit cmake
15
16PACKAGECONFIG ??=""
17PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
18
14EXTRA_OECMAKE = " \ 19EXTRA_OECMAKE = " \
15 -DWITH_GCRYPT=1 \ 20 -DWITH_GCRYPT=1 \
16 -DWITH_PCAP=1 \ 21 -DWITH_PCAP=1 \
@@ -19,11 +24,6 @@ EXTRA_OECMAKE = " \
19 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \ 24 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
20 " 25 "
21 26
22PACKAGECONFIG ??=""
23PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
24
25inherit cmake
26
27do_configure_prepend () { 27do_configure_prepend () {
28 # Disable building of examples 28 # Disable building of examples
29 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \ 29 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \