summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-01 13:26:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-01 22:34:36 +0100
commit398e7f75bd0f55a7c76c0de627cfda16e82165fa (patch)
tree3ccb8ca0903950ade7f7468b53b111d8cb391d41 /meta-oe/recipes-support/libssh/libssh_git.bb
parentb2e8e2ff0badc5ade340cf08a7112b54967b3dab (diff)
downloadmeta-openembedded-398e7f75bd0f55a7c76c0de627cfda16e82165fa.tar.gz
libssh: Fix branch param and set PV in recipe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_git.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_git.bb b/meta-oe/recipes-support/libssh/libssh_git.bb
new file mode 100644
index 000000000..73b9ec1f4
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4
5DEPENDS = "zlib openssl libgcrypt"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
9
10PV = "0.5.5+gitr${SRCPV}"
11SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-5"
12SRCREV = "43914a5f07702fe292a968322d5ff2627e0431db"
13S = "${WORKDIR}/git"
14
15OECMAKE_BUILDPATH = "${S}/build"
16OECMAKE_SOURCEPATH = "${S}"
17EXTRA_OECMAKE = " \
18 -DWITH_GCRYPT=1 \
19 -DWITH_PCAP=1 \
20 -DWITH_SFTP=1 \
21 -DWITH_ZLIB=1 \
22 "
23EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
24
25inherit cmake
26
27do_configure_prepend () {
28 # Disable building of examples
29 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' CMakeLists.txt \
30 || bb_fatal "Failed to disable examples"
31}