summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-07-27 04:18:04 -0400
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:42 -0700
commite01afc3f17cbe51eb49debf94f0a761c8660c26e (patch)
tree9034762526536e0c9328d3e83381cd21ef671cab /meta-oe/recipes-support/libssh/libssh_0.7.3.bb
parentae7f8f79c37de19bb2e17024cf2bf4f5e09bd12b (diff)
downloadmeta-openembedded-e01afc3f17cbe51eb49debf94f0a761c8660c26e.tar.gz
libssh: upgrade to 0.7.3
Changelog: version 0.7.3 (released 2016-01-23) * Fixed CVE-2016-0739 * Fixed ssh-agent on big endian * Fixed some documentation issues Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit d71cccd4cbd6bc5a764cc769a65ef5507efb767b) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.7.3.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.7.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.7.3.bb b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
new file mode 100644
index 000000000..c0b8913e1
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4
5DEPENDS = "zlib openssl libgcrypt"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
9
10SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
11SRCREV = "cdf7690e038230623cbbf6b024ece62f41efa98d"
12S = "${WORKDIR}/git"
13
14EXTRA_OECMAKE = " \
15 -DWITH_GCRYPT=1 \
16 -DWITH_PCAP=1 \
17 -DWITH_SFTP=1 \
18 -DWITH_ZLIB=1 \
19 -DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')} \
20 "
21
22PACKAGECONFIG ??=""
23PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
24
25inherit cmake
26
27do_configure_prepend () {
28 # Disable building of examples
29 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
30 || bbfatal "Failed to disable examples"
31}
32
33FILES_${PN}-dev += "${libdir}/cmake"