diff options
author | Max Krummenacher <max.oss.09@gmail.com> | 2019-12-11 13:46:58 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-13 18:29:14 -0800 |
commit | a04e0ed79fc9ad048301cafc5c3a79502e466e5c (patch) | |
tree | 9d0c29082fa8532beb1b8231a24163c12b9b969d /meta-oe/recipes-support/libsoc | |
parent | ba5fbb239e66b9d201bfffa3436d20003b17786f (diff) | |
download | meta-openembedded-a04e0ed79fc9ad048301cafc5c3a79502e466e5c.tar.gz |
libsoc: use python3 for python bindings
With python in PACKAGECONFIGS and with the removal of python2 from
host tools the recipe fails to build. Change the recipe to use python3.
libsoc configure uses the host python to detect the used version,
install and use the python3-native package to have the same version
for host and target.
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libsoc')
-rw-r--r-- | meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb index 01708df35a..8b773aefa5 100644 --- a/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb +++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb | |||
@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/jackmitch/libsoc" | |||
7 | LICENSE = "LGPLv2.1" | 7 | LICENSE = "LGPLv2.1" |
8 | LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5" | 8 | LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5" |
9 | 9 | ||
10 | inherit autotools pkgconfig python-dir | 10 | inherit autotools pkgconfig python3-dir |
11 | 11 | ||
12 | SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb" | 12 | SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb" |
13 | SRC_URI = "git://github.com/jackmitch/libsoc.git" | 13 | SRC_URI = "git://github.com/jackmitch/libsoc.git" |
@@ -21,7 +21,7 @@ PACKAGECONFIG ?= "" | |||
21 | PACKAGECONFIG[disabledebug] = "--disable-debug,," | 21 | PACKAGECONFIG[disabledebug] = "--disable-debug,," |
22 | PACKAGECONFIG[allboardconfigs] = "--with-board-configs,," | 22 | PACKAGECONFIG[allboardconfigs] = "--with-board-configs,," |
23 | PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},," | 23 | PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},," |
24 | PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}" | 24 | PACKAGECONFIG[python] = "--enable-python=${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN},,${PYTHON_PN} ${PYTHON_PN}-native" |
25 | 25 | ||
26 | PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \ | 26 | PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \ |
27 | '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}" | 27 | '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}" |