summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/liboop
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-14 18:09:39 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:23:23 +0100
commit226ea3d8b1bf5c9d5ed560a1c9cb7060199ac177 (patch)
tree7584e141ae3cb6a4d2c01a9bf58e277f7676d0e1 /meta-oe/recipes-support/liboop
parent29881464a7a2e36a29ce7d87be929f840f5e9a55 (diff)
downloadmeta-openembedded-226ea3d8b1bf5c9d5ed560a1c9cb7060199ac177.tar.gz
liboop: Add recipe
liboop is needed by ruli Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/liboop')
-rw-r--r--meta-oe/recipes-support/liboop/liboop/explicit_linking.patch20
-rw-r--r--meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch11
-rw-r--r--meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch40
-rw-r--r--meta-oe/recipes-support/liboop/liboop/tcl_dev.patch22
-rw-r--r--meta-oe/recipes-support/liboop/liboop_1.0.bb23
5 files changed, 116 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch b/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch
new file mode 100644
index 000000000..05d3bf6f4
--- /dev/null
+++ b/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch
@@ -0,0 +1,20 @@
1--- a/Makefile.am
2+++ b/Makefile.am
3@@ -51,7 +51,7 @@ noinst_PROGRAMS = test-oop
4
5 test_oop_SOURCES = test-oop.c
6 test_oop_CFLAGS = $(GLIB2_CFLAGS) $(GLIB_INCLUDES) $(TCL_INCLUDES) $(WWW_INCLUDES)
7-test_oop_LDADD = $(lib_LTLIBRARIES)
8+test_oop_LDADD = $(lib_LTLIBRARIES) $(GLIB2_LIBS) $(ADNS_LIBS) $(TCL_LIBS) $(READLINE_LIBS)
9
10 release: dist
11 gzip -dc $(PACKAGE)-$(VERSION).tar.gz | bzip2 -9 \
12--- a/liboop-glib2.pc.in
13+++ b/liboop-glib2.pc.in
14@@ -7,5 +7,5 @@ Name: liboop-glib2
15 Description: Event loop management library (GLIB2 support)
16 Version: @VERSION@
17 Requires: liboop = @VERSION@ glib-2.0
18-Libs: -L${libdir} -loop-glib2
19+Libs: -L${libdir} -loop-glib2 @GLIB2_LIBS@
20 Cflags: -D_REENTRANT -I${includedir}
diff --git a/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch b/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch
new file mode 100644
index 000000000..0a0242032
--- /dev/null
+++ b/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch
@@ -0,0 +1,11 @@
1--- a/test-oop.c
2+++ b/test-oop.c
3@@ -180,7 +180,7 @@ static void *stop_readline(oop_source *s
4 static void add_readline(oop_source *src) {
5 rl_callback_handler_install(
6 (char *) "> ", /* readline isn't const-correct */
7- (VFunction *) on_readline);
8+ (rl_vcpfunc_t *) on_readline);
9 oop_readline_register(src);
10 src->on_signal(src,SIGQUIT,stop_readline,NULL);
11 }
diff --git a/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch b/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch
new file mode 100644
index 000000000..1880a241a
--- /dev/null
+++ b/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch
@@ -0,0 +1,40 @@
1From: Ian Jackson <ijackson@chiark.greenend.org.uk>
2Applied-Upstream: no
3Bug-Debian: http://bugs.debian.org/579604
4Subject: oop-read.h bugfixes
5
6Some years ago I contributed a feature for reading lines and records
7to liboop: oop-read.h and read.c. Since it took a while for that
8feature to make it into distributed versions, for a long time I've
9been using my own copy of the source file. It seems that I fixed a
10couple of bugs in my copy which are still in the Debian package. I
11can't find any record of me having told anyone about them and now I
12find that 1.0-6 still has the bugs.
13
14There are two fixes:
15 * Initialise "rd->discard" properly
16 * Avoid rd->neednotcheck becoming negative
17
18--- a/read.c
19+++ b/read.c
20@@ -114,6 +114,7 @@ oop_read *oop_rd_new(oop_source *oop, oo
21 rd->allocbuf= 0;
22 rd->used= 0;
23 rd->alloc= buf ? bufsz : 0;
24+ rd->discard= 0;
25 rd->neednotcheck= 0;
26 rd->displacedchar= -1;
27 rd->style= *OOP_RD_STYLE_IMMED;
28@@ -235,7 +236,11 @@ static void *on_process(oop_source *oop,
29
30 if (rd->discard) {
31 rd->used -= rd->discard;
32- rd->neednotcheck -= rd->discard;
33+ if (rd->neednotcheck > rd->discard) {
34+ rd->neednotcheck -= rd->discard;
35+ } else {
36+ rd->neednotcheck= 0;
37+ }
38 memmove(buf, buf + rd->discard, rd->used);
39 rd->discard= 0;
40 }
diff --git a/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch b/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
new file mode 100644
index 000000000..e738be54c
--- /dev/null
+++ b/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
@@ -0,0 +1,22 @@
1--- a/configure
2+++ b/configure
3@@ -19935,7 +19935,7 @@
4 fi
5
6 if test xno != x$with_tcl; then
7- for version in 8.4 8.3 8.2 8.1 8.0 ; do
8+ for version in "" 8.4 8.3 8.2 8.1 8.0 ; do
9 CPPFLAGS="$save_cppflags -I/usr/include/tcl$version"
10 as_ac_Lib=`echo "ac_cv_lib_tcl$version''_Tcl_Main" | $as_tr_sh`
11 echo "$as_me:$LINENO: checking for Tcl_Main in -ltcl$version" >&5
12--- a/configure.ac
13+++ b/configure.ac
14@@ -71,7 +71,7 @@
15 fi
16
17 if test xno != x$with_tcl; then
18- for version in 8.4 8.3 8.2 8.1 8.0 ; do
19+ for version in "" 8.4 8.3 8.2 8.1 8.0 ; do
20 CPPFLAGS="$save_cppflags -I/usr/include/tcl$version"
21 AC_CHECK_LIB(tcl$version,Tcl_Main,[
22 AC_CHECK_HEADER(tcl.h,[
diff --git a/meta-oe/recipes-support/liboop/liboop_1.0.bb b/meta-oe/recipes-support/liboop/liboop_1.0.bb
new file mode 100644
index 000000000..82818c242
--- /dev/null
+++ b/meta-oe/recipes-support/liboop/liboop_1.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Liboop is a low-level event loop management library for POSIX-based operating systems"
2HOMEPAGE = "http://liboop.org/"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8b54f38ccbd44feb80ab90e01af8b700"
5
6SRC_URI = "http://ftp.debian.org/debian/pool/main/libo/liboop/liboop_${PV}.orig.tar.gz \
7 file://read_bugfixes.patch \
8 file://explicit_linking.patch \
9 file://tcl_dev.patch \
10 file://new-readline-typedef.patch \
11"
12
13SRC_URI[md5sum] = "36cb971047d3af02369446f5e0b315a2"
14SRC_URI[sha256sum] = "34d83c6e0f09ee15cb2bc3131e219747c3b612bb57cf7d25318ab90da9a2d97c"
15
16PACKAGECONFIG ?= ""
17PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
18PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0 libpcre"
19PACKAGECONFIG[tcl] = "--with-tcl,--without-tcl,tcl"
20
21EXTRA_OECONF += "--without-adns -without-libwww"
22
23inherit autotools pkgconfig