summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libiio/libiio_git.bb
diff options
context:
space:
mode:
authorNandor Han <nandor.han@vaisala.com>2021-10-01 15:41:33 +0300
committerKhem Raj <raj.khem@gmail.com>2021-10-01 08:17:12 -0700
commite078ffd4ce182ad8d6861e1e21a52a1c514861d3 (patch)
tree09e9ff719b55a3069a7b375a6be262d0bcbd49b4 /meta-oe/recipes-support/libiio/libiio_git.bb
parent3630c30185dd5a3dc29b10a3ccbe40f19ad9aa93 (diff)
downloadmeta-openembedded-e078ffd4ce182ad8d6861e1e21a52a1c514861d3.tar.gz
libiio: depend on avahi only when network backed is used
The `avahi` dependency is needed only when network backend is used. The current dependency configuration will add the `avahi` dependency regardless if network backend is used or not. Move the `avahi` dependency to be part of `PACKAGECONFIG` configuration which will insert the dependency only when needed. Signed-off-by: Nandor Han <nandor.han@vaisala.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libiio/libiio_git.bb')
-rw-r--r--meta-oe/recipes-support/libiio/libiio_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
index 6ac534a28..488d4e3b0 100644
--- a/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -18,7 +18,6 @@ DISTUTILS_SETUP_PATH ?= "${B}/bindings/python/"
18 18
19DEPENDS = " \ 19DEPENDS = " \
20 flex-native bison-native libaio \ 20 flex-native bison-native libaio \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
22" 21"
23 22
24inherit cmake python3native systemd setuptools3 23inherit cmake python3native systemd setuptools3
@@ -31,8 +30,13 @@ EXTRA_OECMAKE = " \
31 30
32PACKAGECONFIG ??= "usb_backend network_backend serial_backend" 31PACKAGECONFIG ??= "usb_backend network_backend serial_backend"
33 32
33NETWORK_BACKEND_DEPENDENCIES = "\
34 libxml2 \
35 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
36"
37
34PACKAGECONFIG[usb_backend] = "-DWITH_USB_BACKEND=ON,-DWITH_USB_BACKEND=OFF,libusb1 libxml2" 38PACKAGECONFIG[usb_backend] = "-DWITH_USB_BACKEND=ON,-DWITH_USB_BACKEND=OFF,libusb1 libxml2"
35PACKAGECONFIG[network_backend] = "-DWITH_NETWORK_BACKEND=ON,-DWITH_NETWORK_BACKEND=OFF,libxml2" 39PACKAGECONFIG[network_backend] = "-DWITH_NETWORK_BACKEND=ON,-DWITH_NETWORK_BACKEND=OFF, ${NETWORK_BACKEND_DEPENDENCIES}"
36PACKAGECONFIG[serial_backend] = "-DWITH_SERIAL_BACKEND=ON,-DWITH_SERIAL_BACKEND=off,libserialport libxml2" 40PACKAGECONFIG[serial_backend] = "-DWITH_SERIAL_BACKEND=ON,-DWITH_SERIAL_BACKEND=off,libserialport libxml2"
37PACKAGECONFIG[libiio-python3] = "-DPYTHON_BINDINGS=ON,-DPYTHON_BINDINGS=OFF" 41PACKAGECONFIG[libiio-python3] = "-DPYTHON_BINDINGS=ON,-DPYTHON_BINDINGS=OFF"
38 42