summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libiio/libiio_git.bb
diff options
context:
space:
mode:
authorSam Van Den Berge <sam.van.den.berge@gmail.com>2022-02-10 15:15:20 +0100
committerKhem Raj <raj.khem@gmail.com>2022-02-11 09:10:38 -0800
commitc1984fc8f954e8ae42ca5793d6a6339b82cd91bb (patch)
tree3241585afe06af81a210c001562b2489d91336e5 /meta-oe/recipes-support/libiio/libiio_git.bb
parentbbd5c7fb13407475879851c95381e5d6d75564f8 (diff)
downloadmeta-openembedded-c1984fc8f954e8ae42ca5793d6a6339b82cd91bb.tar.gz
libiio: use setuptools functions instead of distutils
Since ca73393a36c4144662ea8570f904154188e9815a in oe-core, setuptools does not inherit from distutils3 anymore. Therefore replace the distutils functions and variables by their setuptools counterparts which are now available. Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libiio/libiio_git.bb')
-rw-r--r--meta-oe/recipes-support/libiio/libiio_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
index 6632f7e64..f33fc0c1c 100644
--- a/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -14,7 +14,7 @@ UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17DISTUTILS_SETUP_PATH ?= "${B}/bindings/python/" 17SETUPTOOLS_SETUP_PATH ?= "${B}/bindings/python/"
18 18
19DEPENDS = " \ 19DEPENDS = " \
20 flex-native bison-native libaio \ 20 flex-native bison-native libaio \
@@ -65,14 +65,14 @@ do_configure() {
65 65
66do_compile() { 66do_compile() {
67 if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then 67 if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then
68 distutils3_do_compile 68 setuptools3_do_compile
69 fi 69 fi
70 cmake_do_compile 70 cmake_do_compile
71} 71}
72 72
73do_install() { 73do_install() {
74 if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then 74 if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then
75 distutils3_do_install 75 setuptools3_do_install
76 fi 76 fi
77 cmake_do_install 77 cmake_do_install
78} 78}