summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libcereal
diff options
context:
space:
mode:
authorAnton Blanchard <anton@ozlabs.org>2021-08-17 21:04:37 +1000
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:58:56 -0700
commit7982a1260fa16832d9a8ec89c4fa36c64d5c96b4 (patch)
tree490417a722009ee44bc846a399cc1d45275086e1 /meta-oe/recipes-support/libcereal
parent8deb9e96df95372d72b6f682864c887ef39a4dba (diff)
downloadmeta-openembedded-7982a1260fa16832d9a8ec89c4fa36c64d5c96b4.tar.gz
cereal: Use GNUInstallDirs instead of hard wiring install directories
On a multilib setup cmake files should go into lib64. Signed-off-by: Anton Blanchard <anton@ozlabs.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libcereal')
-rw-r--r--meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch37
-rw-r--r--meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb4
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch b/meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
new file mode 100644
index 000000000..93114dadd
--- /dev/null
+++ b/meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
@@ -0,0 +1,37 @@
1From c9e60ed064aa2938f71f2cacf79f0bb337812bf8 Mon Sep 17 00:00:00 2001
2From: Anton Blanchard <anton@ozlabs.org>
3Date: Tue, 17 Aug 2021 09:32:43 +1000
4Subject: [PATCH] Use GNUInstallDirs instead of hard wiring install directories
5
6On a multilib setup cmake files should go into lib64.
7
8Upstream-Status: Submitted [https://github.com/USCiLab/cereal/pull/710]
9---
10 CMakeLists.txt | 5 +++--
11 1 file changed, 3 insertions(+), 2 deletions(-)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index b97c1f59..ad574290 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -70,14 +70,15 @@ endif()
18
19 option(CEREAL_INSTALL "Generate the install target" ${CEREAL_MASTER_PROJECT})
20 if(CEREAL_INSTALL)
21+ include(GNUInstallDirs)
22 include(CMakePackageConfigHelpers)
23
24 install(TARGETS cereal EXPORT ${PROJECT_NAME}Targets)
25- install(DIRECTORY include/cereal DESTINATION include)
26+ install(DIRECTORY include/cereal DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
27
28 set(configFile ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}Config.cmake)
29 set(versionFile ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}ConfigVersion.cmake)
30- set(configInstallDestination lib/cmake/${PROJECT_NAME})
31+ set(configInstallDestination ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME})
32
33 configure_package_config_file(
34 ${CMAKE_CURRENT_SOURCE_DIR}/Config.cmake.in
35--
362.31.1
37
diff --git a/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb b/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
index 26b27fa6e..6498bb367 100644
--- a/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
+++ b/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
@@ -16,7 +16,9 @@ PROVIDES += "${PN}-dev"
16 16
17PV .= "+git${SRCPV}" 17PV .= "+git${SRCPV}"
18SRCREV = "64f50dbd5cecdaba785217e2b0aeea3a4f1cdfab" 18SRCREV = "64f50dbd5cecdaba785217e2b0aeea3a4f1cdfab"
19SRC_URI = "git://github.com/USCiLab/cereal.git" 19SRC_URI = "git://github.com/USCiLab/cereal.git \
20 file://0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch \
21 "
20 22
21S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
22 24