summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/inotify-tools
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2016-10-17 23:28:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-25 15:31:17 +0200
commit74d5222967d5c7b9a580388985584fbeb5603ec3 (patch)
tree17567f949fb749dffb70bfbe3d8ad69e70c63284 /meta-oe/recipes-support/inotify-tools
parent00ba3c8bad8637c3c9b5b8b4b58eb3ed4077de5b (diff)
downloadmeta-openembedded-74d5222967d5c7b9a580388985584fbeb5603ec3.tar.gz
inotify-tools: add recipe
inotify-tools is a C library and a set of command-line programs for Linux providing a simple interface to inotify. Signed-off-by: Andrea Galbusera <gizero@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/inotify-tools')
-rw-r--r--meta-oe/recipes-support/inotify-tools/inotify-tools/inotifywait-fix-compile-error-with-GCC-6.patch45
-rw-r--r--meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb23
2 files changed, 68 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/inotify-tools/inotify-tools/inotifywait-fix-compile-error-with-GCC-6.patch b/meta-oe/recipes-support/inotify-tools/inotify-tools/inotifywait-fix-compile-error-with-GCC-6.patch
new file mode 100644
index 000000000..ba042a24b
--- /dev/null
+++ b/meta-oe/recipes-support/inotify-tools/inotify-tools/inotifywait-fix-compile-error-with-GCC-6.patch
@@ -0,0 +1,45 @@
1From 7affb288d6c0726e7b1ebc317a878927b6ef0d02 Mon Sep 17 00:00:00 2001
2From: Andrea Galbusera <gizero@gmail.com>
3Date: Tue, 13 Sep 2016 08:10:29 +0200
4Subject: [PATCH] inotifywait: fix compile error with GCC 6
5
6Fails to compile with misleading-indentation error
7
8| src/inotifywait.c: In function 'output_event_csv':
9| src/inotifywait.c:126:5: error: this 'if' clause does not guard... [-Werror=misleading-indentation]
10| if (filename != NULL)
11| ^~
12| src/inotifywait.c:129:2: note: ...this statement, but the latter is misleadingly indented as if it is guarded by the 'if'
13| printf("%s,", csv_escape( inotifytools_event_to_str( event->mask ) ) );
14| ^~~~~~
15| cc1: all warnings being treated as errors
16
17Fix indentation to resolve.
18
19Upstream-Status: Submitted [https://github.com/rvoicilas/inotify-tools/pull/66]
20
21Signed-off-by: Andrea Galbusera <gizero@gmail.com>
22---
23 src/inotifywait.c | 6 +++---
24 1 file changed, 3 insertions(+), 3 deletions(-)
25
26diff --git a/src/inotifywait.c b/src/inotifywait.c
27index c5ce5e3..404a85b 100644
28--- a/src/inotifywait.c
29+++ b/src/inotifywait.c
30@@ -122,9 +122,9 @@ void validate_format( char * fmt ) {
31
32
33 void output_event_csv( struct inotify_event * event ) {
34- char *filename = csv_escape(inotifytools_filename_from_wd(event->wd));
35- if (filename != NULL)
36- printf("%s,", filename);
37+ char *filename = csv_escape(inotifytools_filename_from_wd(event->wd));
38+ if (filename != NULL)
39+ printf("%s,", filename);
40
41 printf("%s,", csv_escape( inotifytools_event_to_str( event->mask ) ) );
42 if ( event->len > 0 )
43--
441.9.1
45
diff --git a/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb b/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb
new file mode 100644
index 000000000..a8ef55764
--- /dev/null
+++ b/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Command line tools and C library providing a simple interface to inotify"
2AUTHOR = "Rohan McGovern <rohan@mcgovern.id.au>"
3HOMEPAGE = "http://wiki.github.com/rvoicilas/inotify-tools"
4SECTION = "console/devel"
5LICENSE = "GPL-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=ac6c26e52aea428ee7f56dc2c56424c6"
7
8SRCREV = "1df9af4d6cd0f4af4b1b19254bcf056aed4ae395"
9PV = "3.14+git${SRCPV}"
10
11SRC_URI = "git://github.com/rvoicilas/${BPN} \
12 file://inotifywait-fix-compile-error-with-GCC-6.patch \
13 "
14
15S = "${WORKDIR}/git"
16
17inherit autotools
18
19EXTRA_OECONF = "--disable-doxygen"
20
21PACKAGES =+ "libinotifytools"
22
23FILES_libinotifytools = "${libdir}/lib*.so.*"