summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/iksemel/iksemel/fix-configure-option-parsing.patch
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-11-01 15:08:37 -0700
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:34:05 -0800
commit222091bdc218a19a6643a62f70be6cac3371a683 (patch)
tree9a18de2dc984554903894099bd50294b292af73d /meta-oe/recipes-support/iksemel/iksemel/fix-configure-option-parsing.patch
parent0c31b49526028606d09417dc87d180006b8938df (diff)
downloadmeta-openembedded-222091bdc218a19a6643a62f70be6cac3371a683.tar.gz
iksemel: reinstate recipe with build fixes and update 1.4 -> 1.5
The recipe for iksemel 1.4 was blacklisted and eventually removed as it depended on an older version of gnutls which was no longer available in oe-core. Reinstate iksemel with a new recipe for iksemel 1.5, which can use either openssl or gnutls for TLS support. Fix build issues. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/iksemel/iksemel/fix-configure-option-parsing.patch')
-rw-r--r--meta-oe/recipes-support/iksemel/iksemel/fix-configure-option-parsing.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/iksemel/iksemel/fix-configure-option-parsing.patch b/meta-oe/recipes-support/iksemel/iksemel/fix-configure-option-parsing.patch
new file mode 100644
index 000000000..05accdd9c
--- /dev/null
+++ b/meta-oe/recipes-support/iksemel/iksemel/fix-configure-option-parsing.patch
@@ -0,0 +1,62 @@
1From 17a5cf8f70b86d8a2195562e2d9dcccb4fa35c83 Mon Sep 17 00:00:00 2001
2From: Andre McCurdy <armccurdy@gmail.com>
3Date: Tue, 31 Oct 2017 20:05:58 -0700
4Subject: [PATCH] fix configure option parsing
5
6Don't over-write with_openssl etc by trying to set to $enablevar
7
8Upstream-Status: Pending
9
10Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
11---
12 configure.ac | 14 +++++++-------
13 1 file changed, 7 insertions(+), 7 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 82e6d2d..823e6c1 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -56,17 +56,17 @@ fi
20 dnl Options for overriding TLS checks
21 AC_ARG_WITH([openssl],
22 AS_HELP_STRING([--without-openssl],[disable checking for openssl]),
23- [with_openssl=$enableval],
24- [with_openssl=yes]
25+ [],
26+ [with_openssl=auto]
27 )
28 AC_ARG_WITH([gnutls],
29 AS_HELP_STRING([--without-gnutls],[disable checking for GNU TLS]),
30- [with_gnutls=$enableval],
31- [with_gnutls=yes]
32+ [],
33+ [with_gnutls=auto]
34 )
35
36 dnl Check OpenSSL
37-if test "x$with_openssl" = "xyes"; then
38+if test "x$with_openssl" != "xno"; then
39 PKG_CHECK_MODULES([OPENSSL], openssl >= 0.9.8, have_openssl=yes, have_openssl=no)
40 if test "x$have_openssl" = "xyes"; then
41 LIBOPENSSL_CFLAGS="$OPENSSL_CFLAGS"
42@@ -78,7 +78,7 @@ if test "x$with_openssl" = "xyes"; then
43 fi
44
45 dnl Check GNU TLS
46-if test "x$with_gnutls" = "xyes"; then
47+if test "x$with_gnutls" != "xno"; then
48 if test "x$have_openssl" != "xyes"; then
49 PKG_CHECK_MODULES([GNUTLS], gnutls >= 2.0.0, have_gnutls=yes, have_gnutls=no)
50 if test "x$have_gnutls" = "xyes"; then
51@@ -94,7 +94,7 @@ fi
52 dnl Option for overriding Python check
53 AC_ARG_ENABLE([python],
54 AS_HELP_STRING([--disable-python],[disable checking for Python bindings]),
55- [with_python=$enableval],
56+ [],
57 [with_python=yes]
58 )
59
60--
611.9.1
62