summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/htop/htop_3.3.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-01-23 08:58:23 +0800
committerKhem Raj <raj.khem@gmail.com>2024-01-22 18:02:27 -0800
commit110667ac3798b5b64552cb4b8dc706aad8fbcdfe (patch)
tree61167b346551c60f3d1dc107a4f6e33545527dfb /meta-oe/recipes-support/htop/htop_3.3.0.bb
parentd34f54d0876abe045a3201e6a518326dfebf5524 (diff)
downloadmeta-openembedded-110667ac3798b5b64552cb4b8dc706aad8fbcdfe.tar.gz
htop: upgrade 3.2.2 -> 3.3.0
0001-Use-pkg-config.patch refreshed for 3.3.0 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/htop/htop_3.3.0.bb')
-rw-r--r--meta-oe/recipes-support/htop/htop_3.3.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/htop/htop_3.3.0.bb b/meta-oe/recipes-support/htop/htop_3.3.0.bb
new file mode 100644
index 000000000..cd5b766f0
--- /dev/null
+++ b/meta-oe/recipes-support/htop/htop_3.3.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Interactive process viewer"
2HOMEPAGE = "https://htop.dev"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "git://github.com/htop-dev/htop.git;branch=main;protocol=https \
10 file://0001-Use-pkg-config.patch \
11"
12SRCREV = "68c970c7ef4a0682760ed570b3d82388ae7ccf54"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= " \
19 unicode \
20 affinity \
21 delayacct \
22"
23PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
24PACKAGECONFIG[affinity] = "--enable-affinity,--disable-affinity,,,,hwloc"
25PACKAGECONFIG[unwind] = "--enable-unwind,--disable-unwind,libunwind"
26PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc,,,affinity"
27PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
28PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
29PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver"
30PACKAGECONFIG[capabilities] = "--enable-capabilities,--disable-capabilities,libcap"
31PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
32PACKAGECONFIG[sensors] = "--enable-sensors,--disable-sensors,lmsensors,lmsensors-libsensors"
33
34FILES:${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg"
35
36RDEPENDS:${PN} += "ncurses-terminfo-base"