summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gsoap/gsoap_2.8.105.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-08-07 22:43:17 +0800
committerKhem Raj <raj.khem@gmail.com>2020-08-07 00:07:07 -0700
commit074b3d2230f3e665f872d8336a6b7d3bafa39744 (patch)
tree276b49c4a9ecaa0a0781d34a5a61326f0cd4f7db /meta-oe/recipes-support/gsoap/gsoap_2.8.105.bb
parentb0800cc8bf0fb82f727bd88bccf94303b358935c (diff)
downloadmeta-openembedded-074b3d2230f3e665f872d8336a6b7d3bafa39744.tar.gz
gsoap: upgrade 2.8.103 -> 2.8.105
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gsoap/gsoap_2.8.105.bb')
-rw-r--r--meta-oe/recipes-support/gsoap/gsoap_2.8.105.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gsoap/gsoap_2.8.105.bb b/meta-oe/recipes-support/gsoap/gsoap_2.8.105.bb
new file mode 100644
index 000000000..70807de2a
--- /dev/null
+++ b/meta-oe/recipes-support/gsoap/gsoap_2.8.105.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
2for the development of SOAP Web Services and clients."
3SECTION = "devel"
4LICENSE = "GPL-2.0-with-OpenSSL-exception"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \
6 file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \
9 "
10SRC_URI[md5sum] = "ce91e46d3abc1d720566b13298fbc367"
11SRC_URI[sha256sum] = "aa20c535cf08f1576bebad97cc6159ca57c68bc43acfc9a296e4e9faf041097e"
12
13inherit autotools
14
15BBCLASSEXTEND = "native"
16
17S = "${WORKDIR}/${BPN}-2.8"
18
19PARALLEL_MAKE = ""
20
21EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
22
23DEPENDS = "openssl zlib flex bison bison-native"
24DEPENDS_append_class-target = " gsoap-native"
25
26do_install_append() {
27 install -d ${D}${libdir}
28 for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
29 do
30 oe_libinstall -C gsoap $lib ${D}${libdir}
31 done
32}
33
34do_install_class-native() {
35 oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
36}
37
38FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
39FILES_${PN} += "${datadir}"
40FILES_${PN}-staticdev = "${libdir}"
41FILES_${PN}-dev = "${includedir}"
42RRECOMMENDS_${PN}-dev = "${PN}-staticdev"