summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gperftools/gperftools_2.8.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-09-07 21:26:17 +0800
committerKhem Raj <raj.khem@gmail.com>2020-09-08 11:53:53 -0700
commitd7431ca78749de2e38004cef0099706953f8a03b (patch)
treee640960060dc1474a210fe5b31277dd6d1df27e0 /meta-oe/recipes-support/gperftools/gperftools_2.8.bb
parente17cf136a5b9a27aa4a7bac1d4a356b2468da551 (diff)
downloadmeta-openembedded-d7431ca78749de2e38004cef0099706953f8a03b.tar.gz
gperftools: upgrade 2.7.90 -> 2.8
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gperftools/gperftools_2.8.bb')
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools_2.8.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.8.bb b/meta-oe/recipes-support/gperftools/gperftools_2.8.bb
new file mode 100644
index 000000000..662777b47
--- /dev/null
+++ b/meta-oe/recipes-support/gperftools/gperftools_2.8.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
2HOMEPAGE = "https://github.com/gperftools/gperftools"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
5
6SRCREV = "180bfa10d7cb38e8b3784d60943d50e8fcef0dcb"
7SRC_URI = "git://github.com/gperftools/gperftools \
8 file://0001-Support-Atomic-ops-on-clang.patch \
9 file://0001-fix-build-with-musl-libc.patch \
10 file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \
11 file://disable_libunwind_aarch64.patch \
12 file://sgidef.patch \
13 "
14
15inherit autotools
16
17S = "${WORKDIR}/git"
18
19# On mips, we have the following error.
20# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
21# Segmentation fault (core dumped)
22COMPATIBLE_HOST_mipsarch = "null"
23COMPATIBLE_HOST_riscv64 = "null"
24COMPATIBLE_HOST_riscv32 = "null"
25
26# Disable thumb1
27# {standard input}: Assembler messages:
28# {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
29# Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed
30ARM_INSTRUCTION_SET_armv5 = "arm"
31ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
32
33PACKAGECONFIG ?= "libunwind static"
34PACKAGECONFIG_remove_arm_libc-musl = "libunwind"
35PACKAGECONFIG_remove_riscv64 = "libunwind"
36PACKAGECONFIG_remove_riscv32 = "libunwind"
37
38PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
39PACKAGECONFIG[static] = "--enable-static,--disable-static,"
40
41PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
42FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
43
44# pprof tool requires Getopt::long and POSIX perl5 modules.
45# Also runs `objdump` on each cpuprofile data file
46RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix"
47
48RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"
49