summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gnulib
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-13 08:41:17 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-13 19:21:41 -0700
commit6892fc010ab916886d7c75c121a2ad0866c9d39a (patch)
tree32a12cc98b7657c5cb5de1116d0ea7a8f71bf768 /meta-oe/recipes-support/gnulib
parent5288d38ee66667463750caf2d0ed1863e52364ef (diff)
downloadmeta-openembedded-6892fc010ab916886d7c75c121a2ad0866c9d39a.tar.gz
gnulib: Do not use git operations to install the sources
git operations have started to fail with errors like | fatal: unsafe repository ('/mnt/b/yoe/master/build/tmp/work/riscv64-yoe-linux-musl/gnulib/2018-03-07.03-r0/git' is owned by someon e else) | To add an exception for this directory, call: | | git config --global --add safe.directory /mnt/b/yoe/master/build/tmp/work/riscv64-yoe-linux-musl/gnulib/2018-03-07.03-r0/git This is after git has fixed a CVE in 2.35+ see [1] [1] https://github.com/actions/checkout/issues/760 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gnulib')
-rw-r--r--meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
index 2aab68e6a..a27968079 100644
--- a/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
+++ b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
@@ -13,18 +13,15 @@ LICENSE = "LGPL-2.0-or-later"
13LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5" 13LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
14SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3" 14SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3"
15 15
16SRC_URI = "git://git.sv.gnu.org/gnulib.git;branch=master \ 16SRC_URI = "git://git.savannah.gnu.org/git/gnulib.git;branch=master \
17" 17"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit utils
22
23do_install () { 21do_install () {
24 cd ${S} 22 install -d ${D}/${datadir}/gnulib
25 check_git_config 23 cp --no-preserve=ownership --recursive ${S}/* ${D}/${datadir}/gnulib/
26 git checkout master 24 cp --no-preserve=ownership --recursive ${S}/.git ${D}/${datadir}/gnulib/
27 git clone ${S} ${D}/${datadir}/gnulib
28} 25}
29 26
30do_patch[noexec] = "1" 27do_patch[noexec] = "1"