diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-02-17 17:57:38 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-18 13:19:36 -0800 |
commit | 26fe378404f596263ed302488cf8d65d1b2b8dfa (patch) | |
tree | 6cb1132029051cc40de5d765944d755f551aee5d /meta-oe/recipes-support/glog | |
parent | 959182dfa0b51a4577f34f7ba7a6b56e2ba2fde4 (diff) | |
download | meta-openembedded-26fe378404f596263ed302488cf8d65d1b2b8dfa.tar.gz |
glog: Link with libatomics on mips.
Mips does not have 64bit atomic builtins therefore link with libatomic
we might need same for armv5 and ppc32 too.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/glog')
-rw-r--r-- | meta-oe/recipes-support/glog/glog_0.6.0.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/glog/glog_0.6.0.bb b/meta-oe/recipes-support/glog/glog_0.6.0.bb index 18291600c5..067e914aa2 100644 --- a/meta-oe/recipes-support/glog/glog_0.6.0.bb +++ b/meta-oe/recipes-support/glog/glog_0.6.0.bb | |||
@@ -17,15 +17,18 @@ S = "${WORKDIR}/git" | |||
17 | 17 | ||
18 | inherit cmake | 18 | inherit cmake |
19 | 19 | ||
20 | PACKAGECONFIG ?= "shared unwind" | 20 | PACKAGECONFIG ?= "shared unwind 64bit-atomics" |
21 | PACKAGECONFIG:remove:riscv64 = "unwind" | 21 | PACKAGECONFIG:remove:riscv64 = "unwind" |
22 | PACKAGECONFIG:remove:riscv32 = "unwind" | 22 | PACKAGECONFIG:remove:riscv32 = "unwind" |
23 | PACKAGECONFIG:remove:mipsarch = "64bit-atomics" | ||
24 | |||
23 | PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo" | 25 | PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo" |
24 | PACKAGECONFIG:append:libc-musl:riscv32 = " execinfo" | 26 | PACKAGECONFIG:append:libc-musl:riscv32 = " execinfo" |
25 | 27 | ||
26 | PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind" | 28 | PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind" |
27 | PACKAGECONFIG[execinfo] = ",,libexecinfo" | 29 | PACKAGECONFIG[execinfo] = ",,libexecinfo" |
28 | PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,," | 30 | PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,," |
31 | PACKAGECONFIG[64bit-atomics] = ",-DCMAKE_CXX_STANDARD_LIBRARIES='-latomic',," | ||
29 | 32 | ||
30 | do_configure:append() { | 33 | do_configure:append() { |
31 | # remove WORKDIR info to improve reproducibility | 34 | # remove WORKDIR info to improve reproducibility |