diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2021-05-24 00:33:47 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-24 07:39:35 -0700 |
commit | 08a6ca528311bab9c246977f626577565adf170c (patch) | |
tree | 762404254fbae0ef20d91896821eaaaa12e56c51 /meta-oe/recipes-support/fltk | |
parent | 6c596c4acc1d2b8a2d1f87bec915260f882f1be2 (diff) | |
download | meta-openembedded-08a6ca528311bab9c246977f626577565adf170c.tar.gz |
fltk: upgrade 1.3.5 -> 1.3.6
* DOPTION_BUILD_EXAMPLES was deprecated in favor of FLTK_BUILD_TEST
* FLTK_BUILD_TEST fails for native due to reduced build
* FLTK_BUILD_TEST fails for cross due ti trying to run cross fluid
* Patches: 0002.. adjust / 0003.. upstream has acknowledged it a bad ides so
change was commented out / 0004.. upstreamed
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk')
6 files changed, 19 insertions, 245 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk-native.bb b/meta-oe/recipes-support/fltk/fltk-native.bb index 2636287e3a..5d5a236be9 100644 --- a/meta-oe/recipes-support/fltk/fltk-native.bb +++ b/meta-oe/recipes-support/fltk/fltk-native.bb | |||
@@ -9,12 +9,15 @@ EXTRA_OECMAKE += " \ | |||
9 | -DOPTION_USE_THREADS=OFF \ | 9 | -DOPTION_USE_THREADS=OFF \ |
10 | -DOPTION_USE_XDBE=OFF \ | 10 | -DOPTION_USE_XDBE=OFF \ |
11 | -DOPTION_USE_XFT=OFF \ | 11 | -DOPTION_USE_XFT=OFF \ |
12 | -DOPTION_BUILD_EXAMPLES=OFF \ | 12 | -DFLTK_BUILD_TEST=OFF \ |
13 | -DOPTION_USE_XINERAMA=OFF \ | 13 | -DOPTION_USE_XINERAMA=OFF \ |
14 | -DOPTION_USE_XFIXES=OFF \ | 14 | -DOPTION_USE_XFIXES=OFF \ |
15 | -DOPTION_USE_XCURSOR=OFF \ | 15 | -DOPTION_USE_XCURSOR=OFF \ |
16 | " | 16 | " |
17 | 17 | ||
18 | # lib/libfltk.a(Fl_Native_File_Chooser.cxx.o): undefined reference to symbol 'dlsym@@GLIBC_2.2.5' | ||
19 | LDFLAGS += "-ldl" | ||
20 | |||
18 | do_install_append() { | 21 | do_install_append() { |
19 | # make sure native fltk-config is not used accidentaly | 22 | # make sure native fltk-config is not used accidentaly |
20 | rm -f ${D}${bindir}/fltk-config | 23 | rm -f ${D}${bindir}/fltk-config |
diff --git a/meta-oe/recipes-support/fltk/fltk.bb b/meta-oe/recipes-support/fltk/fltk.bb index 09344cf7d1..51b4a0bc85 100644 --- a/meta-oe/recipes-support/fltk/fltk.bb +++ b/meta-oe/recipes-support/fltk/fltk.bb | |||
@@ -5,14 +5,10 @@ DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft" | |||
5 | inherit features_check binconfig lib_package gtk-icon-cache mime mime-xdg | 5 | inherit features_check binconfig lib_package gtk-icon-cache mime mime-xdg |
6 | REQUIRED_DISTRO_FEATURES = "x11" | 6 | REQUIRED_DISTRO_FEATURES = "x11" |
7 | 7 | ||
8 | SRC_URI += " \ | ||
9 | file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch \ | ||
10 | file://0004-Fix-build-error-when-enable-package-config-examples.patch \ | ||
11 | " | ||
12 | |||
13 | EXTRA_OECMAKE = " \ | 8 | EXTRA_OECMAKE = " \ |
14 | -DOPTION_BUILD_SHARED_LIBS=ON \ | 9 | -DOPTION_BUILD_SHARED_LIBS=ON \ |
15 | -DOPTION_USE_THREADS=ON \ | 10 | -DOPTION_USE_THREADS=ON \ |
11 | -DFLTK_BUILD_TEST=OFF \ | ||
16 | -DOPTION_USE_XDBE=ON \ | 12 | -DOPTION_USE_XDBE=ON \ |
17 | -DOPTION_USE_XFT=ON \ | 13 | -DOPTION_USE_XFT=ON \ |
18 | -DFLTK_CONFIG_PATH=${libdir}/cmake \ | 14 | -DFLTK_CONFIG_PATH=${libdir}/cmake \ |
@@ -20,7 +16,6 @@ EXTRA_OECMAKE = " \ | |||
20 | 16 | ||
21 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" | 17 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" |
22 | 18 | ||
23 | PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,fltk-native" | ||
24 | PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo" | 19 | PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo" |
25 | PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl" | 20 | PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl" |
26 | PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama" | 21 | PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama" |
diff --git a/meta-oe/recipes-support/fltk/fltk.inc b/meta-oe/recipes-support/fltk/fltk.inc index 97a1fbfc7e..403cbddbb5 100644 --- a/meta-oe/recipes-support/fltk/fltk.inc +++ b/meta-oe/recipes-support/fltk/fltk.inc | |||
@@ -11,9 +11,8 @@ SRC_URI = " \ | |||
11 | file://0002-always-build-fluid-and-export-pointers.patch \ | 11 | file://0002-always-build-fluid-and-export-pointers.patch \ |
12 | " | 12 | " |
13 | 13 | ||
14 | PV = "1.3.5" | 14 | PV = "1.3.6" |
15 | SRC_URI[md5sum] = "0de2b45a1896be2b4a8cafae89b84248" | 15 | SRC_URI[sha256sum] = "20d2627c97b4485ee3eab5522303985bc22b798a878ba80239e6d43dcfed067e" |
16 | SRC_URI[sha256sum] = "2933c72400f9e7c0f4c3a81a1ce98bc9582b2a3edc44b8597ccd26e240e32c3c" | ||
17 | 16 | ||
18 | inherit cmake pkgconfig | 17 | inherit cmake pkgconfig |
19 | 18 | ||
diff --git a/meta-oe/recipes-support/fltk/fltk/0002-always-build-fluid-and-export-pointers.patch b/meta-oe/recipes-support/fltk/fltk/0002-always-build-fluid-and-export-pointers.patch index cca977c66d..0d91aab3a1 100644 --- a/meta-oe/recipes-support/fltk/fltk/0002-always-build-fluid-and-export-pointers.patch +++ b/meta-oe/recipes-support/fltk/fltk/0002-always-build-fluid-and-export-pointers.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 16010cb1a69ea2326d8102b7f1e34b65aca4b278 Mon Sep 17 00:00:00 2001 | 1 | From 16010cb1a69ea2326d8102b7f1e34b65aca4b278 Mon Sep 17 00:00:00 2001 |
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | 2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> |
3 | Date: Tue, 28 Feb 2017 01:20:42 +0100 | 3 | Date: Sat, 22 May 2021 12:33:15 +0200 |
4 | Subject: [PATCH] always build fluid and export pointers | 4 | Subject: [PATCH] always build fluid and export pointers |
5 | MIME-Version: 1.0 | 5 | MIME-Version: 1.0 |
6 | Content-Type: text/plain; charset=UTF-8 | 6 | Content-Type: text/plain; charset=UTF-8 |
@@ -8,24 +8,24 @@ Content-Transfer-Encoding: 8bit | |||
8 | 8 | ||
9 | Upstream-Status: Inappropriate [embedded specific] | 9 | Upstream-Status: Inappropriate [embedded specific] |
10 | 10 | ||
11 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | 11 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> |
12 | --- | 12 | --- |
13 | CMake/export.cmake | 2 +- | 13 | CMake/export.cmake | 2 +- |
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/CMake/export.cmake b/CMake/export.cmake | 16 | diff --git a/CMake/export.cmake b/CMake/export.cmake |
17 | index 968186a..95e04eb 100644 | 17 | index 6e8bc5d..71b6f6c 100644 |
18 | --- a/CMake/export.cmake | 18 | --- a/CMake/export.cmake |
19 | +++ b/CMake/export.cmake | 19 | +++ b/CMake/export.cmake |
20 | @@ -21,7 +21,7 @@ | 20 | @@ -20,7 +20,7 @@ |
21 | # final config and export | ||
22 | ####################################################################### | 21 | ####################################################################### |
22 | |||
23 | # Set the fluid executable path | 23 | # Set the fluid executable path |
24 | -if(CMAKE_CROSSCOMPILING) | 24 | -if (CMAKE_CROSSCOMPILING) |
25 | +if(FALSE) | 25 | +if (FALSE) |
26 | find_file(FLUID_PATH | 26 | find_file(FLUID_PATH |
27 | NAMES fluid fluid.exe | 27 | NAMES fluid fluid.exe |
28 | PATHS ENV PATH | 28 | PATHS ENV PATH |
29 | -- | 29 | -- |
30 | 2.9.3 | 30 | 2.31.1 |
31 | 31 | ||
diff --git a/meta-oe/recipes-support/fltk/fltk/0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch b/meta-oe/recipes-support/fltk/fltk/0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch deleted file mode 100644 index 1f2f8aecf7..0000000000 --- a/meta-oe/recipes-support/fltk/fltk/0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | From bc38fb41044503c9debf5710910c51dd29674b6a Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Fri, 15 Dec 2017 22:14:01 +0100 | ||
4 | Subject: [PATCH] CMake build: Force shared libs with unsuffixed names | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | For windows build sake CMake complains when a project wants to build shared and | ||
10 | static libraries with same name. This caused the authors of fltk to generate | ||
11 | libraries with names suffixed by '_SHARED' when building fltk with cmake - | ||
12 | autotools builds do not suffix. | ||
13 | |||
14 | Reasons to build shared libs with correct names: | ||
15 | |||
16 | * Shared libraries are the preferred choice for embedded devices | ||
17 | * There are projects (e.g yoshimi) expecting shared libraries with unsuffixed | ||
18 | names - as created by autotools build. These projects link against static | ||
19 | libraries by accident causing unusable binaries. | ||
20 | |||
21 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
22 | --- | ||
23 | CMake/macros.cmake | 2 +- | ||
24 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
25 | |||
26 | diff --git a/CMake/macros.cmake b/CMake/macros.cmake | ||
27 | index 4def62d..ab675f0 100644 | ||
28 | --- a/CMake/macros.cmake | ||
29 | +++ b/CMake/macros.cmake | ||
30 | @@ -49,7 +49,7 @@ macro(FL_ADD_LIBRARY LIBNAME LIBTYPE LIBFILES) | ||
31 | PROPERTIES | ||
32 | VERSION ${FLTK_VERSION_FULL} | ||
33 | SOVERSION ${FLTK_VERSION_MAJOR}.${FLTK_VERSION_MINOR} | ||
34 | - PREFIX "lib" # for MSVC static/shared coexistence | ||
35 | + OUTPUT_NAME ${LIBNAME} CLEAN_DIRECT_OUTPUT 1 | ||
36 | ) | ||
37 | endif (${LIBTYPE} STREQUAL "SHARED") | ||
38 | |||
39 | -- | ||
40 | 2.9.5 | ||
41 | |||
diff --git a/meta-oe/recipes-support/fltk/fltk/0004-Fix-build-error-when-enable-package-config-examples.patch b/meta-oe/recipes-support/fltk/fltk/0004-Fix-build-error-when-enable-package-config-examples.patch deleted file mode 100644 index 974c02fe61..0000000000 --- a/meta-oe/recipes-support/fltk/fltk/0004-Fix-build-error-when-enable-package-config-examples.patch +++ /dev/null | |||
@@ -1,182 +0,0 @@ | |||
1 | Fix build error when enable package config examples. | ||
2 | |||
3 | Upstream-Status: Backport [https://github.com/fltk/fltk/commit/16774dd] | ||
4 | |||
5 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
6 | |||
7 | |||
8 | From 16774ddc4e000c89e560fde0ced8be9814ef041e Mon Sep 17 00:00:00 2001 | ||
9 | From: Albrecht Schlosser <albrechts.fltk@online.de> | ||
10 | Date: Wed, 8 Feb 2017 02:06:52 +0000 | ||
11 | Subject: [PATCH] Rename test/help demo program to test/help_dialog. | ||
12 | |||
13 | This change avoids a name conflict with CMake's auto-generated target 'help' | ||
14 | for "Unix Makefiles", "Ninja", and supposedly other generators as well. | ||
15 | |||
16 | |||
17 | git-svn-id: file:///fltk/svn/fltk/branches/branch-1.4@12171 ea41ed52-d2ee-0310-a9c1-e6b18d33e121 | ||
18 | --- | ||
19 | CMake/macros.cmake | 5 ----- | ||
20 | documentation/src/examples.dox | 8 +++---- | ||
21 | test/CMakeLists.txt | 27 +++++++++++++++++++---- | ||
22 | test/demo.menu | 2 +- | ||
23 | test/{help.cxx => help_dialog.cxx} | 6 ++--- | ||
24 | test/{help-test.html => help_dialog.html} | 0 | ||
25 | 6 files changed, 31 insertions(+), 17 deletions(-) | ||
26 | rename test/{help.cxx => help_dialog.cxx} (88%) | ||
27 | rename test/{help-test.html => help_dialog.html} (100%) | ||
28 | |||
29 | diff --git a/CMake/macros.cmake b/CMake/macros.cmake | ||
30 | index 5b0d0fa..7134fcb 100644 | ||
31 | --- a/CMake/macros.cmake | ||
32 | +++ b/CMake/macros.cmake | ||
33 | @@ -90,11 +90,6 @@ function(CREATE_EXAMPLE NAME SOURCES LIBRARIES) | ||
34 | |||
35 | set (tname ${NAME}) # target name | ||
36 | |||
37 | - # rename reserved target name "help" (CMake 2.8.12 and later) | ||
38 | - if (${tname} MATCHES "^help$") | ||
39 | - set (tname "test_help") | ||
40 | - endif (${tname} MATCHES "^help$") | ||
41 | - | ||
42 | foreach(src ${SOURCES}) | ||
43 | if ("${src}" MATCHES "\\.fl$") | ||
44 | list(APPEND flsrcs ${src}) | ||
45 | diff --git a/documentation/src/examples.dox b/documentation/src/examples.dox | ||
46 | index 5105b7b..7961b02 100644 | ||
47 | --- a/documentation/src/examples.dox | ||
48 | +++ b/documentation/src/examples.dox | ||
49 | @@ -60,7 +60,7 @@ you build FLTK, unlike those in the 'test' directory shown below. | ||
50 | </tr> | ||
51 | <tr> | ||
52 | <td> \ref examples_hello </td> | ||
53 | -<td> \ref examples_help </td> | ||
54 | +<td> \ref examples_help_dialog </td> | ||
55 | <td> \ref examples_iconize </td> | ||
56 | <td> \ref examples_image </td> | ||
57 | <td> \ref examples_inactive </td> | ||
58 | @@ -326,13 +326,13 @@ easily under FLTK. | ||
59 | tiny demo shows how little is needed to get a functioning application | ||
60 | running with FLTK. Quite impressive, I'd say. | ||
61 | |||
62 | -\subsection examples_help help | ||
63 | +\subsection examples_help_dialog help_dialog | ||
64 | |||
65 | \par | ||
66 | -\c help displays the built-in FLTK help browser. The | ||
67 | +\c help_dialog displays the built-in FLTK help browser. The | ||
68 | Fl_Help_Dialog understands a subset of html and renders | ||
69 | various image formats. This widget makes it easy to provide help | ||
70 | -pages to the user without depending on the operating system's | ||
71 | +pages to the user without depending on the operating system's | ||
72 | html browser. | ||
73 | |||
74 | \subsection examples_iconize iconize | ||
75 | diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt | ||
76 | index 22ec9ab..4caffa5 100644 | ||
77 | --- a/test/CMakeLists.txt | ||
78 | +++ b/test/CMakeLists.txt | ||
79 | @@ -1,3 +1,22 @@ | ||
80 | +# | ||
81 | +# "$Id$" | ||
82 | +# | ||
83 | +# CMakeLists.txt used to build test and demo apps by the CMake build system | ||
84 | +# | ||
85 | +# Copyright 2004-2017 by Bill Spitzak and others. | ||
86 | +# | ||
87 | +# This library is free software. Distribution and use rights are outlined in | ||
88 | +# the file "COPYING" which should have been included with this file. If this | ||
89 | +# file is missing or damaged, see the license at: | ||
90 | +# | ||
91 | +# http://www.fltk.org/COPYING.php | ||
92 | +# | ||
93 | +# Please report all bugs and problems on the following page: | ||
94 | +# | ||
95 | +# http://www.fltk.org/str.php | ||
96 | +# | ||
97 | +####################################################################### | ||
98 | + | ||
99 | set(EXECUTABLE_OUTPUT_PATH ${FLTK_BINARY_DIR}/bin/examples) | ||
100 | |||
101 | ####################################################################### | ||
102 | @@ -64,7 +83,7 @@ CREATE_EXAMPLE(file_chooser file_chooser.cxx "fltk;fltk_images") | ||
103 | CREATE_EXAMPLE(fonts fonts.cxx fltk) | ||
104 | CREATE_EXAMPLE(forms forms.cxx "fltk;fltk_forms") | ||
105 | CREATE_EXAMPLE(hello hello.cxx fltk) | ||
106 | -CREATE_EXAMPLE(help help.cxx "fltk;fltk_images") | ||
107 | +CREATE_EXAMPLE(help_dialog help_dialog.cxx "fltk;fltk_images") | ||
108 | CREATE_EXAMPLE(icon icon.cxx fltk) | ||
109 | CREATE_EXAMPLE(iconize iconize.cxx fltk) | ||
110 | CREATE_EXAMPLE(image image.cxx fltk) | ||
111 | @@ -134,7 +153,7 @@ endif(FLTK_HAVE_CAIRO) | ||
112 | # Note: this is incomplete as of 11 Feb 2015 | ||
113 | # Todo: currently all files are copied, but some of them need configuration: | ||
114 | # - demo.menu: fluid can't be started (wrong path) | ||
115 | -# - demo.menu: help (help-test.html) can't find its images (not copied) | ||
116 | +# - demo.menu: help_dialog (help_dialog.html) can't find its images (not copied) | ||
117 | # - maybe more ... | ||
118 | |||
119 | # prepare for a "better" test file installation path | ||
120 | @@ -149,11 +168,11 @@ configure_file(demo.menu ${TESTFILE_PATH}/demo.menu COPYONLY) | ||
121 | |||
122 | # use target directory only to avoid redundancy | ||
123 | configure_file(rgb.txt ${TESTFILE_PATH} COPYONLY) | ||
124 | -configure_file(help-test.html ${TESTFILE_PATH} COPYONLY) | ||
125 | +configure_file(help_dialog.html ${TESTFILE_PATH} COPYONLY) | ||
126 | configure_file(browser.cxx ${TESTFILE_PATH} COPYONLY) | ||
127 | configure_file(editor.cxx ${TESTFILE_PATH} COPYONLY) | ||
128 | if(APPLE AND NOT OPTION_APPLE_X11) | ||
129 | configure_file(browser.cxx "${TESTFILE_PATH}/browser.app/Contents/Resources/browser.cxx" COPYONLY) | ||
130 | configure_file(rgb.txt ${TESTFILE_PATH}/colbrowser.app/Contents/Resources/rgb.txt COPYONLY) | ||
131 | - configure_file(help-test.html ${TESTFILE_PATH}/help.app/Contents/Resources/help-test.html COPYONLY) | ||
132 | + configure_file(help_dialog.html ${TESTFILE_PATH}/help_dialog.app/Contents/Resources/help_dialog.html COPYONLY) | ||
133 | endif(APPLE AND NOT OPTION_APPLE_X11) | ||
134 | diff --git a/test/demo.menu b/test/demo.menu | ||
135 | index 337a71c..97e522a 100644 | ||
136 | --- a/test/demo.menu | ||
137 | +++ b/test/demo.menu | ||
138 | @@ -77,7 +77,7 @@ | ||
139 | @o:Font Tests...:@of | ||
140 | @of:Fonts:fonts | ||
141 | @of:UTF-8:utf8 | ||
142 | - @o:HelpDialog:help | ||
143 | + @o:HelpDialog:help_dialog | ||
144 | @o:Input Choice:input_choice | ||
145 | @o:Preferences:preferences | ||
146 | @o:Threading:threads | ||
147 | diff --git a/test/help.cxx b/test/help_dialog.cxx | ||
148 | similarity index 88% | ||
149 | rename from test/help.cxx | ||
150 | rename to test/help_dialog.cxx | ||
151 | index f5c51d6..7866641 100644 | ||
152 | --- a/test/help.cxx | ||
153 | +++ b/test/help_dialog.cxx | ||
154 | @@ -3,7 +3,7 @@ | ||
155 | // | ||
156 | // Fl_Help_Dialog test program. | ||
157 | // | ||
158 | -// Copyright 1999-2010 by Easy Software Products. | ||
159 | +// Copyright 2011-2017 by Bill Spitzak and others. | ||
160 | // | ||
161 | // This library is free software. Distribution and use rights are outlined in | ||
162 | // the file "COPYING" which should have been included with this file. If this | ||
163 | @@ -46,13 +46,13 @@ main(int argc, // I - Number of command-line arguments | ||
164 | strcpy(buf, argv[0]); | ||
165 | char *slash = strrchr(buf, '/'); | ||
166 | if (slash) | ||
167 | - strcpy(slash, "/../Resources/help-test.html"); | ||
168 | + strcpy(slash, "/../Resources/help_dialog.html"); | ||
169 | help->load(buf); | ||
170 | |||
171 | #else | ||
172 | |||
173 | if (argc <= 1) | ||
174 | - help->load("help-test.html"); | ||
175 | + help->load("help_dialog.html"); | ||
176 | else | ||
177 | help->load(argv[1]); | ||
178 | |||
179 | diff --git a/test/help-test.html b/test/help_dialog.html | ||
180 | similarity index 100% | ||
181 | rename from test/help-test.html | ||
182 | rename to test/help_dialog.html | ||