summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk/fltk.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-12-11 17:10:36 +0800
committerKhem Raj <raj.khem@gmail.com>2019-12-13 18:29:14 -0800
commitbbecc5dfc4d6da8ff3b4606d7cd24eeb2df0a7bc (patch)
tree0d1052ff6f68b71b46898fc0e261e381c00dbc31 /meta-oe/recipes-support/fltk/fltk.bb
parent52cfe934ccc535c1ccfebb7a43a8d2abcca7a94f (diff)
downloadmeta-openembedded-bbecc5dfc4d6da8ff3b4606d7cd24eeb2df0a7bc.tar.gz
fltk: fix build error when enable package config examples
Backport patch to fix fltk build error when enable package config 'examples'. Drop the useless parts such as .gitignore and Makefile from the patch. fltk-native is also required by package config 'examples'. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk/fltk.bb')
-rw-r--r--meta-oe/recipes-support/fltk/fltk.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk.bb b/meta-oe/recipes-support/fltk/fltk.bb
index 7ad4ac70a..0d033f361 100644
--- a/meta-oe/recipes-support/fltk/fltk.bb
+++ b/meta-oe/recipes-support/fltk/fltk.bb
@@ -5,7 +5,10 @@ DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
5inherit features_check binconfig lib_package gtk-icon-cache mime 5inherit features_check binconfig lib_package gtk-icon-cache mime
6REQUIRED_DISTRO_FEATURES = "x11" 6REQUIRED_DISTRO_FEATURES = "x11"
7 7
8SRC_URI += "file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch" 8SRC_URI += " \
9 file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch \
10 file://0004-Fix-build-error-when-enable-package-config-examples.patch \
11"
9 12
10EXTRA_OECMAKE = " \ 13EXTRA_OECMAKE = " \
11 -DOPTION_BUILD_SHARED_LIBS=ON \ 14 -DOPTION_BUILD_SHARED_LIBS=ON \
@@ -17,7 +20,7 @@ EXTRA_OECMAKE = " \
17 20
18PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" 21PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
19 22
20PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF," 23PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,fltk-native"
21PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo" 24PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo"
22PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl" 25PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl"
23PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama" 26PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama"