summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/debianutils/debianutils_4.4.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-04-26 13:34:24 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-03 20:47:01 +0200
commit015e6c8710d73ce26ed5617dea5b17341a48c445 (patch)
tree2581171a4747c39877c4db085a2e43a514303d39 /meta-oe/recipes-support/debianutils/debianutils_4.4.bb
parentfd984397ebc83262970e681726135ee425e27948 (diff)
downloadmeta-openembedded-015e6c8710d73ce26ed5617dea5b17341a48c445.tar.gz
debianutils: Upgrade to 4.4
License is changed since readlink is dropped from package which was sole package licensed under BSD Additionally fix B != S build too Below is the diff of license change Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/debianutils/debianutils_4.4.bb')
-rw-r--r--meta-oe/recipes-support/debianutils/debianutils_4.4.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/debianutils/debianutils_4.4.bb b/meta-oe/recipes-support/debianutils/debianutils_4.4.bb
new file mode 100644
index 000000000..30dd9a6fa
--- /dev/null
+++ b/meta-oe/recipes-support/debianutils/debianutils_4.4.bb
@@ -0,0 +1,58 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f"
5
6SRC_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/${BPN}_${PV}.tar.gz"
7SRC_URI[md5sum] = "c0cb076754d7f4eb1e3397d00916647f"
8SRC_URI[sha256sum] = "190850cdd6b5302e0a1ba1aaed1bc7074d67d3bd8d04c613f242f7145afa53a6"
9
10inherit autotools
11
12do_configure_prepend() {
13 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
14}
15
16do_install_append() {
17 for app in ${D}${sbindir}/* ${D}${bindir}/*; do
18 mv $app $app.${PN}
19 done
20 if [ "${base_bindir}" != "${bindir}" ]; then
21 # Debian places some utils into ${base_bindir} as does busybox
22 install -d ${D}${base_bindir}
23 for app in run-parts.${PN} tempfile.${PN}; do
24 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
25 done
26 fi
27}
28
29pkg_prerm_${PN} () {
30if [ "x$D" != "x" ]; then
31 echo "can't do u-a offline" ; exit 1
32else
33 for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
34 update-alternatives --remove $app $app.${PN}
35 done
36fi
37}
38
39pkg_postinst_${PN} () {
40if [ "x$D" != "x" ]; then
41 echo "can't do u-a offline" ; exit 1
42else
43 for app in add-shell installkernel mkboot remove-shell ; do
44 update-alternatives --install ${sbindir}/$app $app $app.${PN} 100
45 done
46
47 for app in savelog sensible-browser sensible-editor sensible-pager which ; do
48 update-alternatives --install ${bindir}/$app $app $app.${PN} 100
49 done
50
51 for app in run-parts tempfile ; do
52 update-alternatives --install ${base_bindir}/$app $app $app.${PN} 100
53 done
54fi
55}
56
57
58