summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cyaml
diff options
context:
space:
mode:
authorNathan BRIENT <n.brient@technologyandstrategy.com>2023-12-21 16:19:57 +0100
committerKhem Raj <raj.khem@gmail.com>2023-12-22 06:39:32 -0800
commita21124a3209ac767c0e607aafe91bda880090c21 (patch)
tree10cd1d4d5b7e8cd6ddf7f77d6d87baaf843c70b6 /meta-oe/recipes-support/cyaml
parent33245220ad91d13a57516615d87653d2de563bd1 (diff)
downloadmeta-openembedded-a21124a3209ac767c0e607aafe91bda880090c21.tar.gz
cyaml: new recipe
Signed-off-by: Nathan BRIENT <n.brient@technologyandstrategy.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cyaml')
-rw-r--r--meta-oe/recipes-support/cyaml/cyaml_1.4.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cyaml/cyaml_1.4.1.bb b/meta-oe/recipes-support/cyaml/cyaml_1.4.1.bb
new file mode 100644
index 000000000..f63348a32
--- /dev/null
+++ b/meta-oe/recipes-support/cyaml/cyaml_1.4.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Cyaml library"
2DESCRIPTION = "LibCYAML is a library for reading and writing structured YAML documents."
3HOMEPAGE = "https://github.com/tlsa/libcyaml"
4SECTION = "libs"
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fe6f0e49348c87bddd5d27803dceaaf0"
7DEPENDS = " \
8 libyaml \
9"
10SRCREV = "07ff8654a270ec9b410acd3152b60de9e9f941af"
11
12SRC_URI = "git://github.com/tlsa/libcyaml.git;protocol=https;branch=main"
13
14S = "${WORKDIR}/git"
15
16inherit pkgconfig
17
18EXTRA_OEMAKE = "'PREFIX=""' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}' 'LIBDIR=${libdir}' 'INCLUDEDIR=${includedir}' 'VARIANT=release'"
19
20do_compile() {
21 oe_runmake
22}
23do_install() {
24 oe_runmake install
25}
26
27CFLAGS += "-pedantic -Wall -Wextra -O3 -Iinclude" \ No newline at end of file